3

I want to use LaTex in Xubuntu 18.04.1. But it is not possible, because after the very first installation command

$ sudo apt-get install texlive-latex-extra

Firefox does not run properly anymore. It gets permanently blocked with the message "a web page is slowing down your browser". One can click on "stop it", and then it runs again, but this happens every time and is not tolerable. The only way out seems to be, to uninstall lexlive-latex-extra again. Then Firefox runs fine again. What to do about that?

Following the suggestions from StackOverflow of Jun 7 I have added the output of apt-cache policy firefox texlive-latex-extra:

firefox:
  Installed: 67.0.1+build1-0ubuntu0.18.04.1
  Candidate: 67.0.1+build1-0ubuntu0.18.04.1
  Version table:
 *** 67.0.1+build1-0ubuntu0.18.04.1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        100 /var/lib/dpkg/status
     59.0.2+build1-0ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
texlive-latex-extra:
  Installed: 2017.20180305-2
  Candidate: 2017.20180305-2
  Version table:
 *** 2017.20180305-2 500
        500 http://us.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status

I have 8 GB RAM. I have never put addons into Firefox. It is just the Firefox which came down with the latest software upgrade.

More information: Following your suggestions I played around. firefox --safe-mode does not fix it. But then I found, that this happens only, if I enter "us.yahoo.com" as internet address. If I start something else on the internet, then firefox runs fine.

But I always start firefox with "us.yahoo.com" from a launcher. That is where the international financial news is. I need that. If I start without the "us." as "yahoo.com" only, then firefox also runs ok. But since I live in the Philippines, then yahoo starts automatically as "ph.yahoo.com". I cannot use that.

I have included the output of firefox for this case:

[Parent 4357, Gecko_IOThread] WARNING: pipe error (102): Connection reset by peer: file /build/firefox-gHMaBx/firefox-67.0.1+build1/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 357
IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PLayerTransaction::Msg_ReleaseLayer Processing error: message was deserialized, but the handler returned false (indicating failure)

IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PLayerTransaction::Msg_ReleaseLayer Processing error: message was deserialized, but the handler returned false (indicating failure)


###!!! [Parent][MessageChannel] Error: (msgtype=0x1F0088,name=PBrowser::Msg_Destroy) Closed channel: cannot send/recv


###!!! [Child][MessageChannel] Error: (msgtype=0x360113,name=PContent::Msg_DetachBrowsingContext) Closed channel: cannot send/recv

[Parent 4357, Gecko_IOThread] WARNING: pipe error (132): Connection reset by peer: file /build/firefox-gHMaBx/firefox-67.0.1+build1/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 357
  • 2
    Do you have any addons in Firefox regarding latex after installation ? You might want to disable any latex addons. – thecarpy Jun 7 at 6:57
  • 2
    Please add output of the command apt-cache policy firefox texlive-latex-extra to the question by editing it. I can' t reproduce this on clean upgraded 18.04 LTS and I do not see how Firefox is related to LaTeX (the texlive filelist contains nothing about this). Did you tried to run Firefox in Safe Mode (firefox --safe-mode) with texlive-latex-extra installed? How much RAM do you have? – N0rbert Jun 7 at 7:17
1

The problem is not urgent anymore. After playing around I found that the international version of yahoo can also be started with "www.yahoo.com". That has the same effect as "us.yahoo.com". But "us.yahoo.com" freezes firefox if LaTex is installed, while "www.yahoo.com" does that not. So I can work again.

Regards and thanks for the suggestions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.