2

I can't get suspend or hibernate or any kind of standby to work with a HP Spectre x360 (15-df012ng) with an Nvidia GTX 1050 Ti video adapter onboard.

  • in the Ubuntu 19.04 Live version, suspend seems to do something but immediately wakes up. Not ideal but I guess this would be solvable.
  • in a freshly installed version of 19.04, where only the 418.56 nvidia driver was installed via ubuntu-drivers, the system goes into suspend and never comes back. I need to press the power button for 10 seconds to make a hard restart.
  • in desperation I tried to make at least hibernate to work to have at least some sort of standby. Made a 32 GB swap file and activated it as swap. Does not work either (makes a normal restart despite the explicit entry in the /etc/default/grub)

Blacklisting nouveau does not help since NVIDIA is the mod.

Due to the fact that it somewhat works in live mode, I'm almost certain the problem is centered around the NVIDIA driver.

Any help or idea how to debug would be very appreciated. All articles I found were several years old and regarding 4.x kernels at best.

Edit: I now tried suspend with 6 different distributions (live versions), latest version each: MX, Manjaro Gnome+KDE, Mint, Suse, Fedora. Interestingly, none of the live versions does even load NVIDIA modules. Suspend does not work in a single one. Bios offers not a single setting option on this.

  • Considering how fast modern hardware boots and shuts down there's really no purpose in using either suspension or hibernation, other than keeping your session as is, with all the apps open. But there are solutions for that. I would then suggest redirecting your efforts towards finding tutorials for that and forget about suspending or hibernating. – user880592 Jun 7 '19 at 17:40
  • Gabriela, thank you for your reply. Yes, but, no. Debug sessions or notebooks with many variables in kernel can be very time intensive to restore. Not an option for my work. – Nric Jun 7 '19 at 23:53
0

I discovered this last night and it works for me,

systemctl suspend -i

I got that from an error message running 'systemctl suspend' from terminal and it told me there were busy (or uninterruptible) processses and to try the -i option.

update: withdrawn as a solution, kept as a hint... didnt work any more. I need to unplug the usb hub before suspending, dont need the -i, and then plug the usb hib back in after coming out of suspend with the power button

how do you issue the command before unplugging the usb keyboard?

sleep 5 ; suspend

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.