10

I am looking for a driver for the TP-Link AC600 Archer T2U Nano, on Kubuntu 18.04 (kernel version 4.15.0-51-generic).

I already tried different drivers, none of them worked.

  • Hardware recommendations questions fit poorly in this site although pertinent in some cases. Not yours though. I would be better to post a question about the one you already have, describing what you tried already and how it didn't work. – user880592 Jun 6 '19 at 16:11
  • I agree, but due to the focus on driver support, I decided to consult askubuntu instead of Hardware recommendations, since they explicitly do not handle compatibility queries as stated here. I do not want to waste hours of time getting a specific dongle to work, when there are working solutions on the market. – André Jun 6 '19 at 16:38
  • 1
    What did the T2U show for an ID in lsusb? – Jeremy31 Jun 6 '19 at 17:22
  • @Jeremy31 it shows Bus 003 Device 010: ID 2357:011e without any description. I removed any drivers already, though. – André Jun 7 '19 at 8:22
15

For the T2U with ID 2357:011e do

sudo apt install git dkms
git clone https://github.com/jeremyb31/rtl8812au-1.git
cd rtl8812au-1
sudo ./dkms-install.sh

Secure Boot will need to be disabled. The github repo name is a little misleading as the source code supports rtl8812au, rtl8814au, and rtl8821au

  • 1
    Thanks, it works. I updated the question to fit the answer. – André Jun 7 '19 at 9:54
  • I found I had to run chmod 777 * before sudo ./dkms-install.sh to make everything executable, maybe because I had pre-extracted the .zip file onto a flash drive to bring it to the PC with the WiFi adapter. – Jordan Rieger Jul 27 '19 at 6:40
  • This worked for me, for a TP-LINK AC600, ARCHER T2U Nano, on 19.04, purchased from amazon UK yesterday. No need to chmod anything. THANK YOU – 0atman Aug 6 '19 at 17:56
  • it worked for me. after installing this driver like this, I enabled the wireless interface as described at askubuntu.com/posts/833894/revisions – mustafa Aug 13 '19 at 7:14
  • 1
    Thank you, it worked perfectly. I documented my process here: gist.github.com/electron0zero/de0eaa13336042bad347f4dbd8749609 – Suraj Nath Oct 30 '19 at 15:18
3

For a more stable driver, try this:

    sudo apt install git dkms
    git clone https://github.com/aircrack-ng/rtl8812au.git
    cd rtl8812au
    sudo ./dkms-install.sh
  • 2
    This is a duplicate of a previous answer – damadam Nov 26 '19 at 15:37
  • 2
    I disagree that this answer is a duplicate. It proposes using a different driver repo, aircrack-ng/rtl8812au, which is basically upstream of jeremyb31/rtl8812au-1 suggested by the other answer. That fork seems less maintained than the one here, so possibly this one might actually even be the better solution. – Byte Commander Dec 1 '19 at 14:13
  • At the time the question was asked the aircrack-ng did not support the device. On 11 Nov 2019 this commit was added providing support – Jeremy31 Jan 19 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.