23

I am looking for a driver for the TP-Link AC600 Archer T2U Nano, on Kubuntu 18.04 (kernel version 4.15.0-51-generic).

$ lsusb
Bus 003 Device 004: ID 2357:011e TP-Link 802.11ac WLAN Adapter

$ inxi -N | grep "TP-Link"
  Device-3: TP-Link 802.11ac WLAN Adapter type: USB driver: usb-network

I already tried different drivers, none of them worked.

2
  • 1
    What did the T2U show for an ID in lsusb?
    – Jeremy31
    Jun 6 '19 at 17:22
  • @Jeremy31 it shows Bus 003 Device 010: ID 2357:011e without any description. I removed any drivers already, though.
    – André
    Jun 7 '19 at 8:22
38

For a more stable driver, try this:

sudo apt install git dkms
git clone https://github.com/aircrack-ng/rtl8812au.git
cd rtl8812au
sudo make dkms_install
15
  • 2
    This is a duplicate of a previous answer
    – damadam
    Nov 26 '19 at 15:37
  • 8
    I disagree that this answer is a duplicate. It proposes using a different driver repo, aircrack-ng/rtl8812au, which is basically upstream of jeremyb31/rtl8812au-1 suggested by the other answer. That fork seems less maintained than the one here, so possibly this one might actually even be the better solution.
    – Byte Commander
    Dec 1 '19 at 14:13
  • 2
    At the time the question was asked the aircrack-ng did not support the device. On 11 Nov 2019 this commit was added providing support
    – Jeremy31
    Jan 19 '20 at 15:58
  • 3
    This should be the accepted answer. The repo in this answer really provides a much, much more stable driver.
    – bteo
    Jan 28 '20 at 14:25
  • 1
    This should be the accepted answer because it has the most up to date drivers. May 18 '20 at 20:15
20

For the T2U with ID 2357:011e do

sudo apt install git dkms
git clone https://github.com/jeremyb31/rtl8812au-1.git
cd rtl8812au-1
sudo ./dkms-install.sh

Secure Boot will need to be disabled. The github repo name is a little misleading as the source code supports rtl8812au, rtl8814au, and rtl8821au

With recent changes you will need to

sudo apt install git dkms
git clone https://github.com/aircrack-ng/rtl8812au.git
cd rtl8812au
sudo make dkms_install

This code doesn't include the rtl8814au for that you need

sudo apt install git dkms
git clone https://github.com/aircrack-ng/rtl8814au.git
cd rtl8814au
sudo make dkms_install
9
  • 1
    Thanks, it works. I updated the question to fit the answer.
    – André
    Jun 7 '19 at 9:54
  • I found I had to run chmod 777 * before sudo ./dkms-install.sh to make everything executable, maybe because I had pre-extracted the .zip file onto a flash drive to bring it to the PC with the WiFi adapter. Jul 27 '19 at 6:40
  • This worked for me, for a TP-LINK AC600, ARCHER T2U Nano, on 19.04, purchased from amazon UK yesterday. No need to chmod anything. THANK YOU
    – 0atman
    Aug 6 '19 at 17:56
  • 1
    Thank you, it worked perfectly. I documented my process here: gist.github.com/electron0zero/de0eaa13336042bad347f4dbd8749609
    – Suraj
    Oct 30 '19 at 15:18
  • 1
    Seeing the following error.. ERROR (dkms apport): binary package for rtl8812au: 5.3.4 not found Error! Bad return status for module build on kernel: 5.4.0-47-generic (x86_64) Consult /var/lib/dkms/rtl8812au/5.3.4/build/make.log for more information. Finished running dkms install steps.
    – Apurv
    Sep 16 '20 at 15:08
1

For the TP-link AC600 Archer T2Uv3 (2357:011f): choose v5.6.4.2 of the driver from aircrack-ng. With the stable v5.3.4 it seems to function correctly, but disconnects randomly every ~5 minutes. (Ubuntu 16.04)

1

Here is a link that addressed issues I was having thanks to an update from Jags: Driver for the TP-Link AC600 Archer T2U Nano, on Kubuntu 18.04 Previous fix from June 6 didn't work for me

sudo apt update
sudo apt install dkms

git clone -b v5.6.4.2 https://github.com/aircrack-ng/rtl8812au.git

cd rtl8812au
sudo ./dkms-install.sh
1
  • Thanks! I have Ubuntu 18.04 with a Lenovo Y510P and worked with this one.
    – chila
    Aug 7 '20 at 13:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.