13

PC: Razer Blade 15" advanced model (mid.2019)

Wifi card: Intel Wifi AX200 OS: Ubuntu 18.04.2

Issue: I'm unable to get the wifi working, even tho bluetooth works fine


Kernel has already been updated + apt update && apt upgrade

razer@razer-Blade:~$ uname -sr
Linux 5.1.7-050107-generic

Wifi still remains undetected

razer@razer-Blade:~$ rfkill list
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
10

The package backport-iwlwifi-dkms from the PPA canonical-hwe-team/pc-oem-dkms works for both kernel versions 4.15 and 5.0, the current HWE kernel. However, you need to install the package while running kernel 4.15. With kernel 5.0, you get an error during the package installation.

After the package has been successfully installed, just reboot your system, and your wifi should be working.

| improve this answer | |
  • Thanks its work on elementaryos install at Razer Studio 2019 – Pamungkas Jayuda Dec 30 '19 at 4:07
  • This worked with my Ubunto 18.04 + ASUS PCE AX3000 card w/ Intel AX200 chipset. Thank you. – WillZ Apr 10 at 21:04
  • backport-iwlwifi-dkms seems to be buggy for my Intel® Wi-Fi 6 AX200 on Ubuntu 20.04. It works but it introduces considerable lags. For example, whenever I open a webpage I have to wait for about 2 seconds until it starts loading. – Shreck Ye Jun 12 at 20:57
7

Because you have already updated your kernel, here is another option for you.

You can try the linux-oem-osp1 kernel and update linux-firmware to the latest version. This kernel is for certified OEM machines, based on 19.04's 5.0 kernel, AX200 support has been backported. I recommend this method because the packages are officially supported.

$ sudo apt install linux-oem-osp1 linux-firmware

Alternatively, for those who want to stick with the default 4.15 kernel in 18.04, you can use simply install backport-iwlwifi-dkms from Ubuntu archive:

$ sudo apt install backport-iwlwifi-dkms

The backport-iwlwifi-dkms package used to be in the canonical-hwe-team/pc-oem-dkms PPA, but now it's available in the standard Ubuntu archive, saving you the trouble of adding a PPA.

| improve this answer | |
  • 1
    This totally did the trick for my HP Pavillion 15 - cs3073cl. Nothing else did. Backports did not work. Also before running the above step I enabled NVIDIA drivers: cyberciti.biz/faq/… Turned off nomodeset in the grub startup and installed intel-microcode (not sure if that helped or hurt) – Steve Owens Mar 24 at 1:06
5

Please refers to this post: https://unix.stackexchange.com/questions/518571/locating-drivers-for-intel-ax200-wireless-on-5-1-kernel

The author received a response from Intel. The driver itself has not made it into the kernel, therefore they suggested using their backport driver (which has now made wi-fi accessible on my laptop [mid-2019 Razer Blade])

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/core_release

| improve this answer | |
  • 2
    Could you please guide me on how to install the backport driver? I saw there is an instruction under "How to install the driver" section in this page. But, is that for a specific Intel Wifi 6 AX200 device? – IgNite Mar 16 at 16:19
2

Just upgrade to the latest Linux Kernel, >5.1, and use the latest firmware for the Wireless adapter: https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html

If you don't mind installing a new operating system, start with Ubuntu 19.10 daily build which has the latest Linux Kernel and firmware. It works out of the box: http://cdimage.ubuntu.com/daily-live/current/

| improve this answer | |
  • still having the same issue after upgrading to the lastest daily 19.10 build for today (17 aug. 19) and trying to copy .ucode file into the firmware folder – lolo Aug 17 '19 at 11:39
  • @lolo I had a similar problem with two of my new laptops and they both got resolved after just upgrading the Kernel to 5.2. Make sure the Kernel is actually > 5.1: uname -a – vahid-dan Aug 18 '19 at 13:47
  • 1
    This worked for me. I downloaded and install the 5.1.1 kernel: kernel.ubuntu.com/~kernel-ppa/mainline/v5.1.1 and then I downloaded and installed the wireless adapter firmware into /lib/firmware/ : wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi/… – Nathan Aug 28 '19 at 14:26
1

Here are the Canadian Instructions:

Intel AX200 instructions.png

You can install any kernel you want in Ubuntu:

without having to upgrade your desktop (eg 16.04 -> 18.04 -> 19.04) in order to get a new kernel version. Upgrading your desktop can result in operations loss (won't boot), in a steep learning curve and loss of functionality (but usually offset by gains in new functionality). Backups are strongly recommended when upgrading desktop. So you should plan carefully if all you want is a new kernel. Upgrading just a kernel (and keeping desktop) doesn't require a backup because the old kernel is still there to boot from.

| improve this answer | |
0

For my case, kernel 4.15.0-62 (ubuntu 16.04), with the use of backport driver as state by Anthony Wong,installing the driver from https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networking.html. The wifi work for me (not at 1Mbps).

| improve this answer | |
  • Did you encounter the SSL error: ... similar to that in this post? I tried following the guide here but couldn't sudo make install successfully. – IgNite Mar 16 at 17:41
  • erm, i never encounter this error, i follw the instructions in the readme in the archive downloaded from the above link – Midas Apr 7 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.