1

So for some reason on my laptop I suffer from severe throttling issues when bdprochot is enabled, putting my cpu at a measly 400 MHz from it's 2.8 cap according to cpufreq-info and 380 mhz from 2.6 according to windows task manager.

It persists across 3 different drives, 7 reinstalls of windows 10 and 7 reinstalls of 3 different linux distros. I've tried it on steam OS, Ubuntu gamepack and Lubunt. In windows I used throttle stop but that's not a thing on linux. I use an external fan lowering my temps with bdprochot off through throttlestop to the lower 40s and even without it I generally cap out at 67 and avg at 50 as such I'm not to concerned about the rumored heating issues from bdprochot.

I tried the msr tools fix but that doesn't work I get the message saying

wrmsr: pwrite: Operation not permitted.

This is a laptop so there are no bios power settings.

I followed a guide here (quote below)

I came across the same problem and I found a solution which works for me. You'll have to download cpufrequtils.

Run every command in Terminal: Note: The '-c' argument is for core number. If your CPU has four cores, run the given command for 0 through 3 and if your CPU has eight cores, then run the command for 0 through 7.

sudo cpufreq-set -c 0 -g performance
sudo cpufreq-set -c 1 -g performance
sudo cpufreq-set -c 2 -g performance
sudo cpufreq-set -c 3 -g performance
sudo cpufreq-set -c XX -g performance
sudo modprobe msr
sudo rdmsr 0x1FC

The XX here is the number of your core. After this step you'll get an output which you need to note down and then use in the next command.

sudo wrmsr 0x1FC XXXXX 

Here, XXXXX is the output from the previous command execution. Finally, to check if it has worked, run:

cpufreq-info

I excluded the line due to the fact that it cause an error output

 sudo cpufreq-set -c XX -g performance

This worked on steam OS which is based on debrian 8: jessie but doesn't seem to work on lubuntu it only seems to edit the settings to performance

The output from rdmsr changes every time I reboot.

it's also sort of a pain to deal with all these commands every time I launch just to make my pc usuable.

I changed the secure boot to on when I swapped to lubuntu in order to add the boot file to the load order so that might be whats preventing wrmsr from working.

Even then it doesn't change the inherent problem that this issue persists as well as the fact that I have to spend time in the command line every time I boot up which let's face it is a huge headache.

Specs

  • Model # Acer Spin SP-513-51-51PB-N16W1

  • CPU Intel i5-6200U @2.3Ghz dual core 4 logical cores

  • Ram: 16 gig DDR4

  • Hard drive: NVMe m.2 ssd 1tb

  • GPU: Intel hd 520

  • OS: Dual boot of Windows 10 home Ver 1809 KB4497934 and Lubuntu 18.04.2

    • The Ram and SSD are upgrades
  • please edit your question adding the actual msr registers and the values you tried to write to. I have heard of attempting to disable PROCHOT via changing bit 0 of 0X1FC from 1 to 0 working for some and not others. What is your processor make and model? – Doug Smythies Jun 6 at 3:11
  • @DougSmythies sorry for the late relpy I was asleep I'll fix it asap. – Mage in the Barrel Jun 6 at 13:12
  • Okay all done adding info lemme know if there's something else you need – Mage in the Barrel Jun 6 at 13:44
  • This is a hardware problem. bdprochot kicks in when the processor gets to hot. "It persists across 3 different drives, windows 10 and 3 different linux distros." That should already indicate it is not a problem related to the OS and thus not Ubuntu, and makes it off topic.Easiest and probably most desirable fix: Underclock your cpu (and/or Gpu). It would fix it for any OS. Another option: check the thermal paste; that needs to be there and correctly applied. If not the processor will get a lot hotter than desired. Do you still have guarantee on it? If so I would return the machine if possible. – Rinzwind Jun 6 at 14:49
  • continued "disable bd prochot permanently " nope. If you do you will fry your processor. Fix the problem not a result of the problem ;-) – Rinzwind Jun 6 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.