2

So I've been battling with trying to setup my SMB shares for several hours now and in all my googling can't seem to figure out the solution.

The problem as I've identified it is that my user doesn't actually have write permissions to the folders where I mounted the shares via fstab. I am able to read/write files is I browse to the other locations > servername > sharename but not if they're mounted via fstab.

I've tried using chown and chmod on the files along with sudo nautilus to change the owner/permissions but get no output or it changes back instantly - also tried changing the force user value in the smb.conf but no luck.

also found this suggestion so I tried adding it to the fstab entry but didn't seem to change anything:

guest,uid=myuser,iocharset=utf8,file_mode=0777,dir_mode=0777,noperm 0 0

Here's what I've got for fstab (one entry, they're basically all the same):

//192.168.1.90/media/Plex /media/Plex cifs shareuser 0 0

and here's what I've got for smb.conf on the server (for one of the shares, they're basically the same):

[NextCloud]
comment = NextCloud Data
path = /Media/NextCloud
public = yes
writeable = yes
browsable = yes
create mask = 0755
directory mask = 0755
force user = root

Basic setup info

Server: Proxmox running Samba - shares are ZFS pools

Client: Ubuntu using fstab to mount shares so that I can point Plex and Nextcloud to those shares (they're running in SNAP)

Hopefully I provided enough info but if not LMK and I'll be happy to get you more if it helps you help me - thanks!

0

I am not an expert but I have done something similar to what you are doing. I gave up trying to setup fstab entry. At best for me it did nothing and at worst stopped the os from booting. Instead I created a file named rc.local in /etc/ with #!/bin/bash -e at the begining and used mount command and its worked ever since.

Also make sure /media has +x permitions so that shareuser can access files/directorys in it and force user = root is probably a security issue

  • Thanks! This is definitely something I'll look into. - I'll try and edit the /media permissions but that was more or less my problem as chmod and chown didn't seem to change anything even running as sudo/root Yeah, Force User = root is not ideal for sure but it's the only way I've been able to get writing to work on windows and ubuntu. – royalba94 Jun 5 at 21:45
  • Glad I could help, basically when a drive is mounted, it replaces the permissions of the folder that it is listed as. – jon Jun 5 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.