0

when i run the following circuit via ngspice(Lubuntu 18.04),

circuit
V 0 1  DC 10
R 0 1 5
.end

it outputs this:

Circuit: circuit


ngspice 1 ->

"print all" leads to this:

Circuit: circuit


ngspice 1 -> print all
false = 0.000000e+00
true = 1.000000e+00
boltz = 1.380620e-23
c = 2.997925e+08
e = 2.718282e+00
echarge = 1.602190e-19
i = 0.000000e+00,1.000000e+00
kelvin = -2.73150e+02
no = 0.000000e+00
pi = 3.141593e+00
planck = 6.626200e-34
yes = 1.000000e+00

Why is there no circuit-specific output?

Thanks in advance

0

There is no circuit-specific output because you haven't simulated anything yet.

The most basic simulation you can do is op, which performs a DC operating point analysis:

$ ngspice test.cir
******
** ngspice-27 : Circuit level simulation program
** The U. C. Berkeley CAD Group
** Copyright 1985-1994, Regents of the University of California.
** Please get your ngspice manual from http://ngspice.sourceforge.net/docs.html
** Please file your bug-reports at http://ngspice.sourceforge.net/bugrep.html
** Creation Date: Tue Dec 26 17:10:20 UTC 2017
******

Circuit: circuit

ngspice 1 -> op
Doing analysis at TEMP = 27.000000 and TNOM = 27.000000



No. of Data Rows : 1
ngspice 1 -> print all
v(1) = -1.00000e+01
v#branch = -2.00000e+00
ngspice 1 -> 
  • Alright, thank you my friend. I was following the description from the book "DC.pdf" by Tony R. Kuphaldt(last update 2006). He used the windows version 2g.6 of SPICE and in my opinion it provides a way better organized output including "total power dissipation"(page 68) even without the "op-simulation-step". I guess there is no way to emulate that behaviour in ngspice. Anyway the main-problem ist solved. – technaton Jun 6 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.