-1

The problem

So today i tried creating a dual boot of ubuntu gampeack alongside windows 10 (windows 10 was installed first) however they would not boot even if I opened up the boot menu for windows via f12, when I went into disk management I saw that there was no boot partition, only two partitions which could both be deleted with gamepack and 1 partition that can be deleted in lubuntu.

things I tried

  • Looking it up
    • I've found a lot of stuff find stuff about grub being missing from the menu but still existing, but nothing about not having the boot sector missing period.
  • Using boot repair tool on gamepack
    • It went through it's usually messages but did not fix the missing boot sector.
  • Using boot reapir tool on lubuntu 19.04
    • it just booted straight to the lubuntu desktop instead of the tool.
  • Using boot reapir disk on lubuntu 18.04.2

    • exhibted the same hhavior as gamepack here's a pastebin output from the too.
  • opening cmd and running "bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi" as an admin.

  • Resinstalled via a Lubuntu 18.04.2 disk using gpt

    • Grub is still missing from the windows boot list and it still goes straight to windows with the boot partition missing
  • Deleting the lubuntu 19.04 partition and reinstalling with a Lubuntu 18.04.2 disk

  • swapping from uefi (no mbr option exists) to legacy mode in bios to check if it was there.

Notes

  • My lubuntu was 19.04 Disco Dingo (LXQt) downloaded from here.
    • Ive also tried 18.04.2 from the same location.
  • My Gamepack was downloaded from here.
  • A few images of of my disk manager are located here
    • the one surounded by my failed attept at a rectangle is the one linux is installed on.
  • Both windows and linux were installed in UEFI mode.
  • According to this page a boot sector is not needed for ubuntu but I'm not sure what else could be causing it.
  • I installed linux using the "install ubuntu alongside windows" option after shrinking another partition.
  • I used rufus the burn the disk onto a flash drive

Specs

  • Model # Acer Spin SP-513-51-51PB-N16W1
  • CPU Intel i5-6200U @2.3Ghz dual core
  • Ram: 16 gig DDR4
  • Hard drive: NVMe m.2 ssd 1tb
  • GPU: Intel hd 520
  • OS: Windows 10 home Ver 1809 KB4497934
    • The Ram and SSD are upgrades
  • Was Windows installed in UEFI mode or MBR mode? Also, did you install Ubuntu in UEFI or MBR mode? – Android Dev Jun 5 at 17:59
  • @Android Dev Windows listed as gpt in properties-> volumes which i think means it is uefi I used rufus to burn the disk it onto a flash drive and it was set to mbr for partition scheme and "Bios or Uefi" for target system. Not sure if that's a yes or no to your question but I hope that clears it up. – Mage in the Barrel Jun 5 at 18:07
  • The mode in which Ubuntu installs is determined by whether you boot from the USB stick in MBR or UEFI mode. Do you know which mode you booted in? Basically, if Windows and Ubuntu were not installed in the same mode, you have problems. – Android Dev Jun 5 at 20:46
  • @AndroidDev windows was installed in UEFI according to run -> msinfo32 -> system summary -> bios mode and so was linux. – Mage in the Barrel Jun 5 at 21:33
  • 2
    You have to set trust on Acers. see askubuntu.com/questions/771455/… That assumes you first actually get the .../EFI/ubuntu files installed in the EFI partition. – ubfan1 Jun 5 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.