0

When I take a screenshot (Graphics > Screenshot), the image of the screenshot automatically opens in lximage-qt and I'm allowed to save the image.

  • There are options in the Edit menu to rotate or flip the image. These work.
  • There are options in the View menu to zoom in or out, etc. These work as well.
  • However, I can't get any of the drawing tools to work: I can't draw an arrow, a rectangle, a circle, or add numbers. The mouse pointer does change to cross-hairs but that's about all. (I don't know why the Draw incrementing numbers is stuck at 3.)

 

lximage-qt

dkb@dkb-LuCo:~$ apt list installed | grep lximage-qt

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

lximage-qt-l10n/disco,now 0.14.1-1ubuntu1 all [installed,automatic]
lximage-qt/disco,now 0.14.1-1ubuntu1 amd64 [installed,automatic]
dkb@dkb-LuCo:~$ 
  • I didn't even know the arrow, box, etc options were there on newly created screenshots :) Thanks for telling me. They work on my main 19.10 box which appears to be using the same 0.14.1-1ubuntu1 lximage-qt package. I'll endeavour to look again when I'm using 19.04. – guiverc Jun 5 at 22:35
  • I booted 19.04 (an old QA-test install), updated it and it worked for me. Yes on both this & my main 19.10 box the icon for number-labels shows "3" but I assume that's a simple graphic & chosen number and shouldn't change. Whenever i tried adding numbered labels to my test screenshots the numbers were incremented as expected (1-5). I couldn't re-create issue sorry. – guiverc Jun 5 at 22:50
  • bugs.launchpad.net/ubuntu/+source/lximage-qt/+bug/1831847 on what I saw anyway... (fyi: i was able to re-create my bug issue on tumbleweed (alas not debian) so have thus far concluded it's likely an upstream issue) – guiverc Jun 6 at 7:04
  • I marked it "Affects me too" :) – DK Bose Jun 6 at 7:32
  • 1
    confirmed in debian-testing too, so github.com/lxqt/lxqt/issues/1720 – guiverc Jun 6 at 9:08
2

A comment by a developer of LXQt to a GitHub issue filed by guiverc has this:

Those annotations have many problems; the issues mentioned in this report are just a small part of them.

I didn't like annotations from start because lximage-qt is an image viewer, not an image editor. The PR that introduced them was incomplete but was merged by mistake.

The following comment has this:

The accidental merge happened here: lxqt/lximage-qt#180 (comment). Also, IMO, the most basic functionality that it needed was undo/redo. Later, I found many bugs in it and so, hid it in a recent PR.

Based on this feedback, users of Lubuntu 18.10 or 19.04 may want to use something else to annotate their screenshots:

  • ksnip is "a Qt based cross-platform screenshot tool that provides many annotation features for your screenshots" and is available as a .deb or AppImage from here.
  • flameshot is in the Universe repository with this GitHub homepage.
  • Myself, whilst new to the features of lximage-qtas I only learnt about them due to this report, I believe they can be used. In my testing, by making the image fit-screen, or zoomed in or out beyond original-size I could use the functions correctly; saving and reloading. There will be limits to what you can do with them (not being able to see where shapes will go, and esp. the lack of an undo), but in my workcase I'll be able to work around limitations in the software [I tested only in 19.04 & 19.10]. This will of course be your choice based on your needs. – guiverc Jun 6 at 22:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.