0

I've built a PC for the first time. Before I had an iMac. I've noticed my new built is much louder than my iMac. It's loud all the time even when just surfing the web. Any ideas of how and if it's possible to regulate the noise of the fans on Ubuntu 19.04.

I've counted 5 fans:

1 Case Fan, 1 CPU Fan, 2 Fans part of the Graphic Card, and finally 1 fan part of the power supply.

My PC specs: AMD Ryzen 5 2600 Six-Core Processor, Gigabyte Radeon RX580 Gaming 8GB GDDR5, Motherboard B450M MORTAR (MS-7B89), Corsair Vengeance 2x8GB DDR4 2666MHz, Power Supply Corsair CX550M, Case Cooler Master MASTERBOX MB600L.

sudo sensors-detect

This is only part of the Output:

Some south bridges, CPUs or memory controllers contain embedded sensors. 
Do you want to scan for them? AMD Family 17h thermal sensors... Success! (driver `k10temp') Some Super I/O chips contain embedded sensors. We have to write to standard I/O ports to probe them. This is usually safe. Do you want to scan for Super I/O sensors? (YES/no): YES Trying family `VIA/Winbond/Nuvoton/Fintek'... Yes Found unknown chip with ID 0xd451 Lastly, we can probe the I2C/SMBus adapters for connected hardware monitoring devices. This is the most risky part, and while it works reasonably well on most systems, it has been reported to cause trouble on some systems. Do you want to probe the I2C/SMBus adapters now? (YES/no): YES Using driver `i2c-piix4' for device 0000:00:14.0: AMD KERNCZ SMBus Driver `k10temp' (autoloaded): `Chip `AMD Family 17h thermal sensors' (confidence: 9) No modules to load, skipping modules configuration. Unloading cpuid... OK

This is the Output for sensors after following instructions from Answer by @rtaft

nct6797-isa-0a20
Adapter: ISA adapter
in0:                    +0.50 V  (min =  +0.00 V, max =  +1.74 V)
in1:                    +1.00 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in2:                    +3.41 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in3:                    +3.30 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in4:                    +1.02 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in5:                    +0.14 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in6:                    +0.81 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in7:                    +3.41 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in8:                    +3.31 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in9:                    +1.84 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in10:                   +0.00 V  (min =  +0.00 V, max =  +0.00 V)
in11:                   +0.69 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in12:                   +1.05 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in13:                   +0.68 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in14:                   +1.51 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
fan1:                     0 RPM  (min =    0 RPM)
fan2:                   793 RPM  (min =    0 RPM)
fan3:                   620 RPM  (min =    0 RPM)
fan4:                     0 RPM  (min =    0 RPM)
fan5:                     0 RPM  (min =    0 RPM)
SYSTIN:                 +34.0°C  (high = +80.0°C, hyst = +75.0°C)  sensor = CPU diode
CPUTIN:                 +37.0°C  (high = +115.0°C, hyst = +90.0°C)  sensor = thermistor
AUXTIN0:                +36.5°C  (high = +115.0°C, hyst = +90.0°C)  sensor = thermistor
AUXTIN1:               -128.0°C    sensor = thermistor
AUXTIN2:                +44.0°C    sensor = thermistor
AUXTIN3:                 -1.0°C    sensor = thermistor
SMBUSMASTER 0:          +37.0°C  
PCH_CHIP_CPU_MAX_TEMP:   +0.0°C  
PCH_CHIP_TEMP:           +0.0°C  
PCH_CPU_TEMP:            +0.0°C  
intrusion0:            ALARM
intrusion1:            ALARM
beep_enable:           disabled

amdgpu-pci-1c00
Adapter: PCI adapter
vddgfx:       +0.80 V  
fan1:         731 RPM  (min =    0 RPM, max = 3700 RPM)
temp1:        +34.0°C  (crit = +94.0°C, hyst = -273.1°C)
power1:       31.20 W  (cap = 145.00 W)

k10temp-pci-00c3
Adapter: PCI adapter
Tdie:         +37.2°C  (high = +70.0°C)
Tctl:         +37.2°C 

The output after doing sudo pwmconfig

sudo pwmconfig
# pwmconfig revision $Revision$ ($Date$)
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

Found the following devices:
   hwmon0 is amdgpu
   hwmon1 is nct6797
   hwmon2 is k10temp

Found the following PWM controls:
   hwmon0/pwm1           current value: 81
hwmon0/pwm1 is currently setup for automatic speed control.
In general, automatic mode is preferred over manual mode, as
it is more efficient and it reacts faster. Are you sure that
you want to setup this output for manual control? (n) n
   hwmon1/pwm1           current value: 255
   hwmon1/pwm2           current value: 33
hwmon1/pwm2 is currently setup for automatic speed control.
In general, automatic mode is preferred over manual mode, as
it is more efficient and it reacts faster. Are you sure that
you want to setup this output for manual control? (n) n
   hwmon1/pwm3           current value: 122
hwmon1/pwm3 is currently setup for automatic speed control.
In general, automatic mode is preferred over manual mode, as
it is more efficient and it reacts faster. Are you sure that
you want to setup this output for manual control? (n) n
   hwmon1/pwm4           current value: 122
hwmon1/pwm4 is currently setup for automatic speed control.
In general, automatic mode is preferred over manual mode, as
it is more efficient and it reacts faster. Are you sure that
you want to setup this output for manual control? (n) n
   hwmon1/pwm5           current value: 122
hwmon1/pwm5 is currently setup for automatic speed control.
In general, automatic mode is preferred over manual mode, as
it is more efficient and it reacts faster. Are you sure that
you want to setup this output for manual control? (n) n

Giving the fans some time to reach full speed...
Found the following fan sensors:
   hwmon0/fan1_input     current speed: 733 RPM
   hwmon1/fan1_input     current speed: 0 ... skipping!
   hwmon1/fan2_input     current speed: 788 RPM
   hwmon1/fan3_input     current speed: 625 RPM
   hwmon1/fan4_input     current speed: 0 ... skipping!
   hwmon1/fan5_input     current speed: 0 ... skipping!

Warning!!! This program will stop your fans, one at a time,
for approximately 5 seconds each!!!
This may cause your processor temperature to rise!!!
If you do not want to do this hit control-C now!!!
Hit return to continue: 

Testing pwm control hwmon1/pwm1 ...
  hwmon0/fan1_input ... speed was 733 now 732
    no correlation
  hwmon1/fan2_input ... speed was 788 now 795
    no correlation
  hwmon1/fan3_input ... speed was 625 now 623
    no correlation

No correlations were detected.
There is either no fan connected to the output of hwmon1/pwm1,
or the connected fan has no rpm-signal connected to one of
the tested fan sensors. (Note: not all motherboards have
the pwm outputs connected to the fan connectors,
check out the hardware database on http://www.almico.com/forumindex.php)

Did you see/hear a fan stopping during the above test (n)? n

Testing is complete.
Please verify that all fans have returned to their normal speed.

The fancontrol script can automatically respond to temperature changes
of your system by changing fanspeeds.
Do you want to set up its configuration file now (y)? y
What should be the path to your fancontrol config file (/etc/fancontrol)? 
Loading configuration from /etc/fancontrol ...

Select fan output to configure, or other action:
1) Change INTERVAL     3) Save and quit
2) Just quit           4) Show configuration
select (1-n): 4

Common Settings:
INTERVAL=10


Select fan output to configure, or other action:
1) Change INTERVAL     3) Save and quit
2) Just quit           4) Show configuration
select (1-n): 3

Saving configuration to /etc/fancontrol...
Configuration saved
  • I am using several of this simple solution : Variable Fan Speed Controller quietpc.com/fanmate2 .... Today´s pricing : € 2.76 – Knud Larsen Jun 5 '19 at 10:17
  • 1
    Start out with sensors-detect and note what it detects for each section, particularly the Super I/O section. You may be able to gain access to control the fans connected to the MB via fancontrol. – rtaft Jun 5 '19 at 12:58
  • 1
    What does it say for this line: Trying family `VIA/Winbond/Nuvoton/Fintek'...? It's likely followed with the ID of an unknown chip. – rtaft Jun 5 '19 at 14:20
  • @rtaft Trying family `VIA/Winbond/Nuvoton/Fintek'... Yes Found unknown chip with ID 0xd451 – George G. Jun 5 '19 at 14:26
  • @rtaft Any thing else that could be important? The output was very extensive. I posted what I thought was the most important part of it above. – George G. Jun 5 '19 at 14:30
1

Info from this post:

Add acpi_enforce_resources=lax to the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub, then rebuild the grub config sudo grub-mkconfig -o /boot/grub/grub.cfg. Then reboot. Ensure that those changes are in /boot/grub/grub.cfg

After that, sudo modprobe nct6775. If that succeeds, you should see more info when you run sensors. Then add nct6775 to /etc/modules If it doesnt work we'll need to debug more. That chip is supported in nct6775, but its not in the sensors-detect codebase, which is odd since the same guy maintains both.

The last step is to run sudo pwmconfig, that will create your /etc/fancontrol file.

  • What is it meant here by "the following"? – George G. Jun 6 '19 at 13:43
  • 1
    Add acpi_enforce_resources=lax to the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub. Edited for clarification. – rtaft Jun 6 '19 at 13:49
  • At the moment it looks like this: GRUB_DEFAULT=0 GRUB_TIMEOUT=0 GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" GRUB_CMDLINE_LINUX="" @rtaft should I replace "quiet splash" for "acpi_enforce_resources=lax" or make a comma, or maybe a new line. Sorry I'm a newbie... – George G. Jun 6 '19 at 14:43
  • 1
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_enforce_resources=lax" – rtaft Jun 6 '19 at 14:50
  • How do I "add nct6775 to /etc/modules" I only find /etc/modules-load.d . Thank you for all. Please see output of sensors above in my question. – George G. Jun 6 '19 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.