0

I've removed the default GNOME keybinding to the Super key and I tried to rebind it using gsettings to its own key:

matt@hydrogen:~$ gsettings get org.gnome.settings-daemon.plugins.media-keys custom-keybindings
['/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/']
matt@hydrogen:~$ gsettings get org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/ binding
'<Super>'

Setting it with gsettings works fine, but it doesn't work.

In the GNOME Settings GUI it shows up as "Disabled":

GNOME Settings Custom Keybindings, where the custom keybinding is shown as disabled

But when clicking on it, it shows that it is bound to the Super key: GNOME Settings that shows that the keybinding is set to the Super key

I've considered using xbindkeys, but this unfortunately doesn't support Wayland, which I am currently using. Obviously it seems like GNOME doesn't like me doing this, but are there any possible workarounds?

0

Changing the behaviour of pressing and releasing Super will, as far as I know, require the use of a utility ksuperkey. See my answer here for some more background on ksuperkey and where to find it. One caveat: Probably the utility will work fine in Wayland, but I am not sure.

The first thing you need to do in any case is disable the Super key for showing the overview:

gsettings set org.gnome.mutter overlay-key ''

You could now first try if your own approach now works. If it does, let us know because that would be most straightforward. I doubt it, however, and then you can try using ksuperkey.

Once started, ksuperkey by default redirects pressing and releasing Super to Alt+F1. There are two possible approaches: 1) you rebind Alt+F1 to your custom command (by default in Gnome, it shows the "menu", i.e., the overview) or 2) you redirect to another keyboard combination by launching ksuperkey with the -e option, e.g.

ksuperkey -e 'Super_L=Control_L|space'

will redirect Super to Ctrl+Space.

The utility must be running, so you will need to have it autostart after login.

  • Thanks for your response! It does seem to generate the keycodes correctly except when I'm focused on a GNOME-y window. So for example, in Settings and Terminal it doesn't work at all. – mattrick Jun 5 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.