1

Using this boot workaround, I have been able to install Ubuntu 19.04 on my recently acquired ASUS UX533FN:

  • ASUS BIOS version 202 (already up-to-date)
  • NVidia GeForce MX150 with NVidia proprietary driver 418 installed
  • Linux version 5.0.0-16-generic
  • no Intel microcode update for the moment (dis_ucode_ldr as linux boot param)

Audio is working! For comparison, I haven't been able to have it working on Ubuntu 18.04 LTS.

Now my problem is the CPU temperature is very high! around 70-80°C without doing anything special that'd claim much CPU power - just writing these lines for example... and the fan doesn't run at all.


I have found the following workaround:

sudo prime-select query

If this command returns nvidia, then run:

sudo prime-select intel

then log off.

Result:
When you log back on, check the CPU temperature decreases and reach reasonable values (between 40°C and 50°C for example, depending on the room temperature), and you should hear the fan running when needed.

But this is only a workaround with which the NVIDIA GPU is not used at all...


Questions

How can I have the NVIDIA graphics card and the fan operational, without the CPU temperature going high?

Maybe I should stick with the Intel graphics only? I didn't ask for an NVidia card in the first place... I didn't realize this laptop had an NVidia card when I bought it.

16
  • Current BIOS? What version Nvidia? Is your card supported in Nvidia 430? Why no Intel microcode updates?
    – heynnema
    Jun 4, 2019 at 18:11
  • No Intel microcode update is the only way to boot at the moment. See: bugs.launchpad.net/ubuntu/+source/linux/+bug/1829620
    – Bludzee
    Jun 4, 2019 at 18:34
  • BIOS 202 actually
    – Bludzee
    Jun 4, 2019 at 18:34
  • NVidia driver, I'll check and let you know (the version installed automatically today when installing Ubuntu 19.04).
    – Bludzee
    Jun 4, 2019 at 18:35
  • I have tried upgrading the ASUS BIOS to version 300, the flash utility (in the ASUS system setup) saw it on the USB key but rejected it.
    – Bludzee
    Jun 4, 2019 at 18:38

3 Answers 3

1

To date, the best answer is to use the following workaround:


sudo prime-select intel

then log off.


After that, I have no more temperature issue with my laptop, and the fan does work when needed.

The drawback is that the NVidia GPU is simply not used at all, but it's fine for me. If I'd known this laptop model had an NVidia card when I bought it, I'd have selected the same model but without an NVidia card.

0

If you can't figure a way to cool down your machine with BIOS updates, etc., or Nvidia updates, you might install thermald. It comes with a default .xml configuration file that may require some tweaking to get it customized for your hardware, and for setting the desired temperature.

  • sudo apt-get update

  • sudo apt-get install thermald

Thermald was buggy in early versions of 16.04. Update to 16.04.2 and it should be ok.

Thermald comes with a default configuration file at /etc/thermald/thermal-conf.xml that will control most computers, but may need to be customized for some computers. See man thermal-conf.xml for some details and examples. Once one has modified the configuration file, stop thermald and restart it:

sudo service thermald restart

After installing thermald, I'd stop the thermald process, and run it manually as sudo thermald --no-daemon to watch its actions in real time. This real time info can be used to create your own customized thermal-conf.xml file. See man thermald for more information.

sudo service thermald stop
sudo thermald --no-daemon --loglevel=debug

You can search for thermald here on Ask Ubuntu to see what previous answers there are.

A good starter reference is at https://wiki.ubuntu.com/Kernel/PowerManagement/ThermalIssues

0

I think it's because your NVIDIA is electronically on and drain your battery

To turn off your secondary GPU manually, first find your GPU PCI adress :

lspci | grep "NVIDIA"

$ lspci | grep "NVIDIA"
02:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)

For my case my PCI adress is 02:00.0

Now we can check if your secondary GPU is draining your battery, run :

cat /sys/bus/pci/devices/0000\:**[PCI_ADRESS]**/power/control

If output is "on" then your secondary GPU is forced on and drain your battery To turn it off run :

sudo sh -c 'echo auto > /sys/bus/pci/devices/0000\:[PCI_ADRESS]/power/control'
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.