0

Software Updater has stopped giving me updates. No matter what I check from "Software Updater box, nothing changes.

It seems like there are not updates for my system anymore. However, this should not happen as I have version 16.04 LTS.

My system is a powerbook G4, I have lubuntu version 16.04 LTS installed. I am located in Greece.

I have read several solutions, nothing worked from me

  1. I deleted file sources.list (located in /etc/apt), and I let system recreate it. No result

  2. I used the repogen.simplylinux site to create a new content for my sources.list. No result

Output of sudo apt-get update:

Get:1 http://ports.ubuntu.com/ubuntu-ports xenial InRelease [247 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports xenial-security InRelease [109 kB]
Get:3 http://ports.ubuntu.com/ubuntu-ports xenial-updates InRelease [109 kB]
Get:4 http://ports.ubuntu.com/ubuntu-ports xenial/main powerpc Packages [1142 kB]
Ign:5 http://ports.ubuntu.com/ubuntu-ports xenial/main i386 Packages     
Get:6 http://ports.ubuntu.com/ubuntu-ports xenial/main Translation-en [568 kB]
Get:7 http://ports.ubuntu.com/ubuntu-ports xenial/universe powerpc Packages [7297 kB]                                       
Ign:8 http://ports.ubuntu.com/ubuntu-ports xenial/universe i386 Packages                                                    
Get:9 http://ports.ubuntu.com/ubuntu-ports xenial/universe Translation-en [4354 kB]                                         
Ign:10 http://ports.ubuntu.com/ubuntu-ports xenial/restricted i386 Packages                                                 
Get:11 http://ports.ubuntu.com/ubuntu-ports xenial/restricted Translation-en [2908 B]                                       
Get:12 http://ports.ubuntu.com/ubuntu-ports xenial/multiverse powerpc Packages [121 kB]                                     
Ign:13 http://ports.ubuntu.com/ubuntu-ports xenial/multiverse i386 Packages                                                 
Get:14 http://ports.ubuntu.com/ubuntu-ports xenial/multiverse Translation-en [106 kB]                                       
Ign:5 http://ports.ubuntu.com/ubuntu-ports xenial/main i386 Packages                                                        
Ign:15 http://ports.ubuntu.com/ubuntu-ports xenial-security/restricted i386 Packages                                        
Get:16 http://ports.ubuntu.com/ubuntu-ports xenial-security/restricted Translation-en [2152 B]                              
Get:17 http://ports.ubuntu.com/ubuntu-ports xenial-security/main powerpc Packages [464 kB]                                  
Ign:18 http://ports.ubuntu.com/ubuntu-ports xenial-security/main i386 Packages                                              
Get:19 http://ports.ubuntu.com/ubuntu-ports xenial-security/main Translation-en [267 kB]                                    
Get:20 http://ports.ubuntu.com/ubuntu-ports xenial-security/multiverse powerpc Packages [1716 B]                            
Ign:21 http://ports.ubuntu.com/ubuntu-ports xenial-security/multiverse i386 Packages                                        
Get:22 http://ports.ubuntu.com/ubuntu-ports xenial-security/multiverse Translation-en [2676 B]                              
Get:23 http://ports.ubuntu.com/ubuntu-ports xenial-security/universe powerpc Packages [341 kB]                              
Ign:24 http://ports.ubuntu.com/ubuntu-ports xenial-security/universe i386 Packages                                          
Get:25 http://ports.ubuntu.com/ubuntu-ports xenial-security/universe Translation-en [177 kB]                                
Ign:8 http://ports.ubuntu.com/ubuntu-ports xenial/universe i386 Packages                                                    
Ign:26 http://ports.ubuntu.com/ubuntu-ports xenial-updates/restricted i386 Packages                                         
Get:27 http://ports.ubuntu.com/ubuntu-ports xenial-updates/restricted Translation-en [2272 B]                               
Get:28 http://ports.ubuntu.com/ubuntu-ports xenial-updates/main powerpc Packages [724 kB]                                   
Ign:29 http://ports.ubuntu.com/ubuntu-ports xenial-updates/main i386 Packages                                               
Get:30 http://ports.ubuntu.com/ubuntu-ports xenial-updates/main Translation-en [381 kB]                                     
Get:31 http://ports.ubuntu.com/ubuntu-ports xenial-updates/multiverse powerpc Packages [11,0 kB]                            
Ign:32 http://ports.ubuntu.com/ubuntu-ports xenial-updates/multiverse i386 Packages                                         
Get:33 http://ports.ubuntu.com/ubuntu-ports xenial-updates/multiverse Translation-en [8440 B]                               
Get:34 http://ports.ubuntu.com/ubuntu-ports xenial-updates/universe powerpc Packages [623 kB]                               
Ign:35 http://ports.ubuntu.com/ubuntu-ports xenial-updates/universe i386 Packages                                           
Get:36 http://ports.ubuntu.com/ubuntu-ports xenial-updates/universe Translation-en [312 kB]                                 
Ign:10 http://ports.ubuntu.com/ubuntu-ports xenial/restricted i386 Packages                                                 
Ign:13 http://ports.ubuntu.com/ubuntu-ports xenial/multiverse i386 Packages                                                 
Ign:5 http://ports.ubuntu.com/ubuntu-ports xenial/main i386 Packages                                                        
Ign:15 http://ports.ubuntu.com/ubuntu-ports xenial-security/restricted i386 Packages                                        
Ign:18 http://ports.ubuntu.com/ubuntu-ports xenial-security/main i386 Packages                                              
Ign:21 http://ports.ubuntu.com/ubuntu-ports xenial-security/multiverse i386 Packages                                        
Ign:24 http://ports.ubuntu.com/ubuntu-ports xenial-security/universe i386 Packages                                          
Ign:8 http://ports.ubuntu.com/ubuntu-ports xenial/universe i386 Packages                                                    
Ign:26 http://ports.ubuntu.com/ubuntu-ports xenial-updates/restricted i386 Packages                                         
Ign:29 http://ports.ubuntu.com/ubuntu-ports xenial-updates/main i386 Packages                                               
Ign:32 http://ports.ubuntu.com/ubuntu-ports xenial-updates/multiverse i386 Packages                                         
Ign:35 http://ports.ubuntu.com/ubuntu-ports xenial-updates/universe i386 Packages                                           
Ign:10 http://ports.ubuntu.com/ubuntu-ports xenial/restricted i386 Packages                                                 
Ign:13 http://ports.ubuntu.com/ubuntu-ports xenial/multiverse i386 Packages                                                 
Err:5 http://ports.ubuntu.com/ubuntu-ports xenial/main i386 Packages                                                        
  404  Not Found [IP: 2001:67c:1360:8001::22 80]
Ign:15 http://ports.ubuntu.com/ubuntu-ports xenial-security/restricted i386 Packages                                        
Ign:18 http://ports.ubuntu.com/ubuntu-ports xenial-security/main i386 Packages                                              
Ign:21 http://ports.ubuntu.com/ubuntu-ports xenial-security/multiverse i386 Packages                                        
Ign:24 http://ports.ubuntu.com/ubuntu-ports xenial-security/universe i386 Packages                                          
Ign:8 http://ports.ubuntu.com/ubuntu-ports xenial/universe i386 Packages                                                    
Ign:26 http://ports.ubuntu.com/ubuntu-ports xenial-updates/restricted i386 Packages                                         
Ign:29 http://ports.ubuntu.com/ubuntu-ports xenial-updates/main i386 Packages                                               
Ign:32 http://ports.ubuntu.com/ubuntu-ports xenial-updates/multiverse i386 Packages                                         
Ign:35 http://ports.ubuntu.com/ubuntu-ports xenial-updates/universe i386 Packages                                           
Ign:10 http://ports.ubuntu.com/ubuntu-ports xenial/restricted i386 Packages                                                 
Err:15 http://ports.ubuntu.com/ubuntu-ports xenial-security/restricted i386 Packages                                        
  404  Not Found [IP: 2001:67c:1360:8001::22 80]
Ign:18 http://ports.ubuntu.com/ubuntu-ports xenial-security/main i386 Packages                                              
Ign:21 http://ports.ubuntu.com/ubuntu-ports xenial-security/multiverse i386 Packages                                        
Ign:24 http://ports.ubuntu.com/ubuntu-ports xenial-security/universe i386 Packages                                          
Err:26 http://ports.ubuntu.com/ubuntu-ports xenial-updates/restricted i386 Packages                                         
  404  Not Found [IP: 2001:67c:1360:8001::22 80]
Ign:29 http://ports.ubuntu.com/ubuntu-ports xenial-updates/main i386 Packages                                               
Ign:32 http://ports.ubuntu.com/ubuntu-ports xenial-updates/multiverse i386 Packages                                         
Ign:35 http://ports.ubuntu.com/ubuntu-ports xenial-updates/universe i386 Packages                                           
Fetched 465 kB in 14s (32,1 kB/s)                                                                                           
Reading package lists... Done
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial/main/binary-i386/Packages  404  Not Found [IP: 2001:67c:1360:8001::22 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-security/restricted/binary-i386/Packages  404  Not Found [IP: 2001:67c:1360:8001::22 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-updates/restricted/binary-i386/Packages  404  Not Found [IP: 2001:67c:1360:8001::22 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

Content of sources.list:

###### Ubuntu Main Repos
# deb http://us.archive.ubuntu.com/ubuntu/ xenial main

###### Ubuntu Update Repos
# deb http://us.archive.ubuntu.com/ubuntu/ xenial-security main


deb http://ports.ubuntu.com/ubuntu-ports/ xenial main universe restricted multiverse
deb http://ports.ubuntu.com/ubuntu-ports/ xenial-security restricted main multiverse universe
deb http://ports.ubuntu.com/ubuntu-ports/ xenial-updates restricted main multiverse universe

Update 2: Thank you for answer Oyamasiphula. This is the output (I think did not work)

Update 3: I ran "apt update". This is the output.

Update 4: At first I switched back my sources.list file. So now the content of my sources.list is this. Then sudo apt-update. The output was this

Then I ran: sudo dpkg --remove-architecture i386 and then sudo apt update The output was this. As suggested in the end, I executed apt list --upgradable. The output was this

And then I executed sudo apt upgrade and I got this


I terminated it, as I was not sure for what to do. Can you please explain what just happened here? Was my machine trying to get i386 packages? If yes, why? Also, should I proceed to update?

thank you a lot!!!!

  • Can you please post the error messages. fyi: Lubuntu 16.04 reached the end of it's 3 year supported life last month, only Ubuntu (main) has 5 years of supported life. Note the bottom of wiki.ubuntu.com/XenialXerus/ReleaseNotes/Lubuntu which states "3 years support (until April 2019)" We need the messages to confirm this is your issue though. – guiverc Jun 4 at 8:14
  • If you can't post the messages, upload them somewhere (paste.ubuntu.com for example) and provide links so we can see them). – guiverc Jun 4 at 8:15
  • ok, I did it. I ran "apt update". This is the output paste.ubuntu.com/p/HyQTnfWvST – kagelaris Jun 4 at 9:09
  • The results of apt list --upgradable show that 133 packages can be upgraded, however Lubuntu 16.04 is end of life, so these packages can't be upgraded. Instead you must upgrade Lubuntu from 16.04 to 18.04: How do I upgrade to a newer version of Ubuntu?. – karel Jun 4 at 11:32
1

Since Lubuntu 16.04 went EOL in April 2019, all packages that were specific to Lubuntu will no longer receive updates. However, packages related to Ubuntu main will still receive updates. Considering this, the i386 packages are now removed from the repositories, thus resulting in the error.

Since you are running a PPC system, the i386 packages were never required. To remove them, run:

sudo dpkg --remove-architecture i386

Now, you'll receive updates only for PPC packages in Ubuntu main. To upgrade those packages, run:

sudo apt update && sudo apt upgrade
  • ok, thank you a lot This worked perfectly, thank you. However, some more information, if this is ok 1) Why the errors from i386 packages blocked the ppc packages? I mean, I suppose I should be able to download the ppc packages, even if I had errors regarding the i386 packages. Am I missing something? 2)All the options in "Other Software" tab in "Software Updater" are unticked. Should I tick any of them? 3) If I understood correct, lubuntu 16.04 LTS has reached EOL. However, 16.04LTS is the last lubuntu version available for ppc architecture. So,no more lubuntu for this machine? – kagelaris Jun 4 at 15:48
  • @kagelaris You might have added i386 architecture in the past. 1) There were no i386 packages available in repositories anymore. Ubuntu is expected to update/upgrade if there is no error or conflicts. 2) I'm not sure about which packages you are talking about. 3) Apparently YES. – Kulfy Jun 4 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.