2

I am trying to install Ubuntu 19.04 on my Windows 10 machine on a separate partition. I created unallocated space on my hard disk before the installation as follows.

enter image description here

Then I tried to install Ubuntu via my bootable USB drive. In the middle of the installation, at the step it asks to select the partition, I cannot see my hard disk or any other partitions.

enter image description here

It shows only /dev/sda at Device for boot loader installation options. When I click Intall now button it gives an error.

enter image description here

How can I fix this issue and install Ubuntu on my unallocated space?

2

You've got a single SSD/HDD set up in RAID mode, and the Ubuntu installer won't recognize your SSD until you switch your disk setting in the BIOS from RAID to AHCI.

Making that switch comes with some problems though, as Windows will no longer boot.

You don't need to reinstall Windows...

Below, you'll find two different ways to solve this problem.

Make sure to have a backup of your important Windows files!

Choice #1: Looking at this article https://samnicholls.net/2016/01/14/how-to-switch-sata-raid-to-ahci-windows-10-xps-13/ will show you how to make the change without having to reinstall Windows.

  • Boot to Windows with your current SATA controller configuration
  • Open Device Manager
  • Expand Storage Controllers and identify the Intel SATA RAID Controller
  • View properties of the identified controller
  • On the Driver tab, click the Update driver… button
  • Browse my computer…, Let me pick…
  • Uncheck Show compatible hardware
  • Select Microsoft as manufacturer
  • Select Microsoft Storage Spaces Controller as model #
  • Accept that Windows cannot confirm that this driver is compatible
  • Save changes, reboot to BIOS and change RAID SATA Controller to AHCI
  • Save changes and reboot normally, hopefully to Windows

Now you should be able to install Ubuntu in a dual-boot configuration.

Choice #2: See http://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/

  • Right-click the Windows Start Menu. Choose Command Prompt (Admin).
  • If you don’t see Command Prompt listed, it’s because you have already been updated to a later version of Windows. If so, use this method instead to get to the Command Prompt:
    • Click the Start Button and type cmd
    • Right-click the result and select Run as administrator
  • Type this command and press ENTER: bcdedit /set {current} safeboot minimal
    • If this command does not work for you, try bcdedit /set safeboot minimal
  • Restart the computer and enter BIOS Setup (the key to press varies between systems).
  • Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
  • Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  • Right-click the Windows Start Menu once more. Choose Command Prompt (Admin)
  • Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
    • If you had to try the alternate command above, you will likely need to do so here also: bcdedit /deletevalue safeboot
  • Reboot once more and Windows will automatically start with AHCI drivers enabled.
  • This worked for me. Thank you. – Malintha Jun 4 at 15:56
  • Instead I have an Intel Chipset SATA/PCIe RST premium controller. Would the first solution also work, i.e., is it compatible? – Mitchell van Zuylen Nov 15 at 23:28
  • @MitchellvanZuylen I don't know. – heynnema Nov 15 at 23:48
  • For @heynnema and anybody coming after me. The answer is sort off. It allowed Ubuntu to see the drives however the Windows turned practically unusable. It can be used to install, and then revert back to the original setting. – Mitchell van Zuylen Nov 17 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.