0

I updated my trusty ThinkPad X200 to Xubuntu 19.04 and now I cannot connect to my WiFi Network. WiFi works fine in 18.04.2 but in 19.04 I don't see any WiFi networks when I click the WifI icon. I ran "lshw -C network" in a terminal and I see it listed under "*-network UNCLAIMED". Same issue happens when running regular Ubuntu 19.04. Ethernet works fine and I have it hooked up to that for now.

So far I've tried

  1. Checking if the WiFi switch is off, It's switched on.
  2. Going to Additional Drivers tab in the Software & Updates program, no drivers were found.
  3. Using the firmware found at the bottom of this page, Same results.

Some additional suggestions would be nice.

Edit: Results of lspci -nnk | grep 0280 -A3 as suggested by Chili555

03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 5350 AGN [Echo Peak] Network Connection [8086:423b] Subsystem: Intel Corporation PRO/Wireless 5350 AGN [Echo Peak] Network Connection [8086:1011] Kernel modules: iwlwifi 04:00.0 Memory controller [0580]: Intel Corporation Turbo Memory Controller [8086:444e] (rev 11)

I also did some research and this appears to be caused by a bug in the version of the iwlwifi driver currently in 19.04, it's been fixed according to this Git page but the updates have not been pushed to 19.04 yet I think. I'd update it myself but I don't have that kind of know how yet.

Edit 2: Results of sudo modprobe iwlwifi && dmesg | grep iwl

[ 10.091583] WARNING: CPU: 0 PID: 327 at drivers/net/wireless/intel/iwlwifi/pcie/drv.c:918 iwl_pci_probe+0x172/0x1f0 [iwlwifi] [ 10.091584] Modules linked in: input_leds(+) irqbypass(+) iwlwifi(+) i2400m_usb(+) btusb thinkpad_acpi(+) btrtl btbcm i2400m btintel nvram wmi_bmof drm_kms_helper drm ledtrig_audio wimax serio_raw bluetooth snd_seq_device cfg80211 i2c_algo_bit fb_sys_fops snd_timer ecdh_generic mei_me mei snd syscopyarea sysfillrect sysimgblt soundcore mac_hid sch_fq_codel parport_pc ppdev lp parport ip_tables x_tables autofs4 ahci libahci psmouse lpc_ich i2c_i801 e1000e wmi video [ 10.091621] RIP: 0010:iwl_pci_probe+0x172/0x1f0 [iwlwifi] [ 10.091685] iwl_pci_register_driver+0x24/0x40 [iwlwifi] [ 10.091697] iwl_drv_init+0x89/0x8b [iwlwifi] [ 10.091738] iwlwifi: probe of 0000:03:00.0 failed with error -22

Edit 3: result of sudo modprobe iwlwifi && dmesg | grep iwl after updating the kernel

[ 12.769208] iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control [ 12.813930] iwlwifi 0000:03:00.0: loaded firmware version 8.83.5.1 build 33692 op_mode iwldvm [ 12.880380] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled [ 12.880383] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled [ 12.880384] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled [ 12.880386] iwlwifi 0000:03:00.0: Detected Intel(R) WiMAX/WiFi Link 5350 AGN, REV=0x24 [ 12.984017] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs' [ 13.943893] iwlwifi 0000:03:00.0 wls1: renamed from wlan0 [ 26.499270] iwlwifi 0000:03:00.0: Radio type=0x0-0x1-0x0 [ 26.654883] iwlwifi 0000:03:00.0: Radio type=0x0-0x1-0x0

  • Please edit your question to show the result of the terminal command: lspci -nnk | grep 0280 -A3 Welcome to Ask Ubuntu. – chili555 Jun 3 at 23:48
  • Done, with some added info as well. – Conduit Jun 4 at 0:14
  • Please run: modinfo iwlwifi | grep 432B In my 19.04 installation, your device is covered. Also run: sudo modprobe iwlwifi && dmesg | grep iwl Next, edit your question to add the results. Do you get the errors listed at the git? – chili555 Jun 4 at 0:52
  • modinfo iwlwifi | grep 432B Didn't give any results but sudo modprobe iwlwifi && dmesg | grep iwl did, updated with those results. – Conduit Jun 4 at 1:41
  • This is the exact error listed at the git. I'm studying the process to implement the fix. – chili555 Jun 4 at 1:48
1

I suggest that you try the latest mainline stable kernel from Ubuntu. Please check your architecture; i.e. 32- or 64-bit:

arch

Assumming that it is x86_64, that is, 64-bit, then download these files:

https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.1.6/linux-headers-5.1.6-050106_5.1.6-050106.201905311031_all.deb

https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.1.6/linux-headers-5.1.6-050106-generic_5.1.6-050106.201905311031_amd64.deb

https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.1.6/linux-image-unsigned-5.1.6-050106-generic_5.1.6-050106.201905311031_amd64.deb

https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.1.6/linux-modules-5.1.6-050106-generic_5.1.6-050106.201905311031_amd64.deb

By default, downloads go to your folder Downloads. Open a terminal and run:

cd ~/Downloads
sudo dpkg -i linux*.deb

After installation completes, reboot and show us:

sudo modprobe iwlwifi && dmesg | grep iwl
  • This fixed the issue, thank you! I've still updated the question to show the results of sudo modprobe iwlwifi && dmesg | grep iwl – Conduit Jun 4 at 18:27
  • Looks perfect. Glad it's working! Thanks, also, for proof-testing the solution. I'm certain that others will search for and benefit from it. – chili555 Jun 4 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.