1

I successfully installed to a new SDD via a USB installer, but grub install failed every time I tried, and I had to install it manually. I managed to figure out that the linux "/" dir was at /dev/sdc2 and configure my BIOS to use the right hard drive on boot, but it always puts me in the GRUB command line on startup. I have to type:

set root=(hd0,gpt2)
linux /vmlinuz root=/dev/sdc2 ro
initrd /initrd.img
boot

Then my Ubuntu 18.04.2 LTS installation boots properly. What do I need to do so that GRUB gives me a menu of kernel version options--or even better, just starts up?

-2

Please use Boot-Repair, it will definitely solve the issue. This will reinstall GRUB and add all other OS on the disk.

  • Please do not just post links to soluitons, try to highlight the main ideas from the link while also supplying the link – j-money Jun 3 at 20:57
  • What did it do to solve the problem? It worked but I'm no wiser for it. – Bob Calco Jun 3 at 21:23
  • 1
    It will reinstall the grub – Rishabh Deep Singh Jun 3 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.