I want to learn Linux so I decided to install Ubuntu on my computer that is running Windows 10 now. Unfortunately, the process was not smooth.

I downloaded the ISO from Ubuntu official website and I used Rufus to make the bootable USB using these instructions. The fast boot of Windows 10 was already disabled, and both CSM and Security Boot were also disabled in BIOS. The BIOS is running under UEFI mode. After booting from the USB, I select Install Ubuntu from the GRUB menu. Then it enters the Ubuntu install wizard.

Weird things happen when I access the keyboard layout, after selecting a keyboard layout then clicking the Continue button, the screen just froze there. The mouse cursor stopped and input through the keyboard did not have any reaction. I waited but after two hours it was still freezing at the keyboard layout screen.

I have tried the nomodeset kernel boot option, acpi=off boot option, changed to another version of Ubuntu (16.04, 18.04, 19.04), change to another USB stick, use another USB port, use default BIOS setting, update to newest BIOS, check MD5 of the downloaded ISO, etc. But none of these work for me. The same problem still occurs.

My computer config:

  • CPU: Intel i7 5820K
  • Motherboard: Gigabyte X99 Gaming-G1-WIFI
  • VGA: Sapphire RX Vega 64
  • Boot Mode: UEFI
  • Partition style: GPT
  • Current System: Window 10 1809 64 bit

If anyone has any other suggestions/solutions, it would be greatly appreciated. Thank you!

  • Same problem here. Looking forward to struggling for a long time to get this solved! Did you? I see that you posted this a while ago. – Patrick Da Silva Jul 23 '19 at 12:34
  • Try to disable uefi mode in bios, and see if it helps. – Michal Przybylowicz Jul 23 '19 at 14:42
  • which version of virtualbox? – nobody Jul 25 '19 at 20:31
  • Try another software to create Ubuntu USB installer, just in case. I'm personally like Unetbootin, as it is available for Linux, Windows, and MacOS – adadion Jul 30 '19 at 5:49

Rufus usually hasn't worked for me. Since you're on Windows 10, you could try using Win32DiskImager.

If that doesn't work, I've managed to unofficially flash the USB drive by formatting to FAT32 (The entire drive) then copying all the files from the .iso file to the drive.

| improve this answer | |

I managed to perform the installation by running it using nomodeset. Basically, at the screen where you get asked "Try Ubuntu without installing", "Install Ubuntu" and those other things, you go to "Install Ubuntu" but instead of pressing enter, you press 'e' and you see a terminal-like screen-wide window. Using arrow keys, you go all the way down to 'quiet splash' and just before the word 'quiet', type 'nomodeset'.

This is not a permanent change and only allows you to bypass some visual configuration, I guess, to prevent the screen from freezing. Note : I managed to perform the installation, but now I have some ACPI Error problem that's for another day, and I cannot tell you if they are related. All I know is that Ubuntu was installed... XD

I'll edit this answer if I end up figuring out that my two problems were not related!

| improve this answer | |

I've used rufus before and can confirm that has caused issues such as the OP's. Instead of using that I have used etcher (or balenaEtcher it's called now) with sucess everytime. If you are using the same USB stick I recommend a full format beforehand just to be safe.That should rule out a bad flash/write.

| improve this answer | |

If virtualbox version is >= 6.0.6 is, remove it. Try virtualbox 6.0.4.

I found bugreport

It could be releated to your Problem. After studying changelog

it seems not fixed now.

| improve this answer | |

I had the same problem using VMware. After adding more than one cores and at least 2GB of memory, the problem disappeared for me. It seems the installation process is hungry for resources. Also on https://o7planning.org/de/11327/installieren-von-ubuntu-desktop-auf-vmware it is mentioned to enlarge the used resources.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.