2

I have a 3840x2160 Dell monitor plugged into an HDMI port on a small x86 single-board computer running 18.04. I am not running any GUI (no Gnome, etc.), so all access is via tty and ssh. The Fixed 8x16 font is incredibly small on the 3840x2160 monitor.

I ran dpkg-reconfigure console-setup, but I don't see many good choices. The 16x32 VGA font is a good size, but when I choose it the tty only draws in the upper-left quarter of my monitor. That font says it works with a framebuffer -- perhaps the framebuffer can only draw on 1/4 of the monitor?

Any advice?

Thanks.

4
4

My eyes almost literally got sick and tired of the tiny fonts on Full HD and now 4K screens when I had to log onto the console periodically.

I put the following into my ~/.bashrc and my problems went away:

# Set font when running in console
if [ $TERM == linux ]; then
    /bin/setfont /usr/share/consolefonts/Lat2-Terminus32x16.psf.gz
fi
1
  • Thank you for this! It works on a Raspberry Pi 4 connected to a 4k screen that's running from the console. Makes the text look easily readable. Now because of SEO, I'm just going to write some random terms in hopes that other people find this like I did. Raspbian Buster Lite Terminal Font Small 4K Screen Tiny Size Text Raspberry Pi 4K. – Mark Tomlin Nov 19 '19 at 3:12
1

This is what worked for me from tty3 (ctrl-alt-F3):

  • sudo apt install xfonts-terminus
  • sudo dpkg-reconfigure console-setup
  • keep defaults for first couple of selections
  • choose Terminus for the font
  • choose 16x32
  • do OK, and then WAIT for permanent update (dpkg-reconfigure changes your boot image using update-initramfs).

I suggest you first double check that your terminal is using frame buffer by sudo dd if=/dev/urandom of=/dev/fb0. Your whole screen background will change to noise if your current terminal is using the framebuffer. If you see nothing change then your terminal is not using the frame buffer - it could be very bad for you if you select a font that requires the framebuffer but YMMV.

Apparently fbterm can also be used with TrueType fonts that can be set to arbitrary sizes, but after installing fbterm, reading man pages, and running it with a variety of different options I couldn’t work out how to do so.

There is a better way to change the grub settings to change the font-size on start to avoid this problem in the first place, but watch out for incorrect info out there about how to do it...

Note: I needed this because I needed to use tty to fix my totally borked Ubuntu install, and I couldn't read the ctrl-alt-F3 tty3 terminal on a 4K screen on Dell XPS15. (I deinstalled evolution* but the Ubuntu Gnome login screen requires evolution-data-server something so it wouldn't even boot into Ubuntu any more; fixed by using sudo apt install --reinstall ubuntu-desktop.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.