0

I am trying to install the ubantu 18 TLS on my new thinkpad t580 with SSD (only one drive is there.(windows10 is already installed)

I have created a 99GB of free space partition . (using the disk management tool-->shrink tool in windows. I have 99GB unallocated space)

On windows I have disabled Hibernation.

still I am not able to see the SSD during installation procedure.

Can you please help me to unblock.

2) Right now in my SATA controller settings is RST Mode. what are the issues I come across changing the settings in BIOS to AHCI. will it impact my windows usage?

3) How can I make my SSD be detected. I saw many similar posts but did not get success even after following them.

  • ubantu 18 TLS 18.0x, Hibernet... These things don't exist -- all we can do is assume your meaning. Do you actually mean ACHI or UEFI? What method did you use to create your free space partition? Are you using the same device/drive for dual boot or do you have separate drives? Please proofread your question for errors, add in specifics (exactly what steps have you taken and exactly what problems do you encounter and exactly what steps do you take to reproduce errors) then please make an edit to your post. – Nmath Jun 2 at 19:13
  • 1
    You need to use AHCI & install AHCI driver into Windows. See: dell.com/community/Laptops-General-Read-Only/… & Intel Optane - See Intel response that no performance difference between RAID & AHCI. communities.intel.com/thread/121155 Maximize SATA Capabilities with AHCI samsung.com/global/business/semiconductor/minisite/SSD/global/… – oldfred Jun 2 at 19:39
  • Thank you. I am using Thinpad T580. when I go to Bios I have the option of changing it to AHCI. does it mean its already installed? 2) is there a work around with out changing this – ML learner Jun 2 at 19:45
1

You've got a single SSD set up in RAID mode, and the Ubuntu installer won't recognize your SSD until you switch your disk setting in the BIOS from RAID to AHCI.

Making that switch comes with some problems though, as Windows will no longer boot.

You don't need to reinstall Windows...

Below, you'll find two different ways to solve this problem.

Make sure to have a backup of your important Windows files!

Choice #1: Looking at this article https://samnicholls.net/2016/01/14/how-to-switch-sata-raid-to-ahci-windows-10-xps-13/ will show you how to make the change without having to reinstall Windows.

  • Boot to Windows with your current SATA controller configuration
  • Open Device Manager
  • Expand Storage Controllers and identify the Intel SATA RAID Controller
  • View properties of the identified controller
  • On the Driver tab, click the Update driver… button
  • Browse my computer…, Let me pick…
  • Uncheck Show compatible hardware
  • Select Microsoft as manufacturer
  • Select Microsoft Storage Spaces Controller as model #
  • Accept that Windows cannot confirm that this driver is compatible
  • Save changes, reboot to BIOS and change RAID SATA Controller to AHCI
  • Save changes and reboot normally, hopefully to Windows

Now you should be able to install Ubuntu in a dual-boot configuration.

Choice #2: See http://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/

  • Right-click the Windows Start Menu. Choose Command Prompt (Admin).
  • If you don’t see Command Prompt listed, it’s because you have already been updated to a later version of Windows. If so, use this method instead to get to the Command Prompt:
    • Click the Start Button and type cmd
    • Right-click the result and select Run as administrator
  • Type this command and press ENTER: bcdedit /set {current} safeboot minimal
    • If this command does not work for you, try bcdedit /set safeboot minimal
  • Restart the computer and enter BIOS Setup (the key to press varies between systems).
  • Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
  • Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  • Right-click the Windows Start Menu once more. Choose Command Prompt (Admin)
  • Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
    • If you had to try the alternate command above, you will likely need to do so here also: bcdedit /deletevalue safeboot
  • Reboot once more and Windows will automatically start with AHCI drivers enabled.
  • Thank you. I am planning to use option2. Can I use it for think pad where it is RST Mode. can I use the same thing. Also looks using option2 there is less chance of Windows getting corrupted right? will there be any other issues in general for moving to this AHCI – ML learner Jun 2 at 23:10
  • @MLlearner no problemo. Please remember to accept my answer if it solves your problem. Thanks! – heynnema Jun 3 at 0:34
  • Thank you. Yes I am trying this now will update shortly – ML learner Jun 3 at 0:37
  • I tried option2. when I changed in BIOS I got a setup" warning: All exisiting data stored on the driver will be erased when resetting the controller mode. ". I dont want to loose my data . is there a work around...I am trying this all so that I can install ubantu – ML learner Jun 3 at 0:45
  • 1
    @MLlearner As I mentioned, others have done one choice or the other, and had no problem. If you're following the instructions, it should work for you too. But, of course, you did backups first, as the instructions say, yes? If so, then the risks would be lower if the procedure didn't work as expected. Sorry I can't be of more help here. – heynnema Jun 3 at 2:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.