1

I have two home computers. One is running 16.04 and the other had 14.04 installed. The 14.04 machine has since been upgraded to 18.04.

When it was 14.04 and 16.04, connecting the two computers directly with an Ethernet cable was a straightforward matter. I'd set static IPs via an dialog like the one below and I'd be ready.

enter image description here

It's not as straightforward with 18.04, apparently. Before my attempt to pair the two computers with the cable, I was using a Wired connection 1 to connect to the Internet on the 18.04 machine -- I'd just plug it in and I'd be online in seconds. After the pairing attempt, not only were the two machines not seeing each other on the private network as I was expecting, but Wired connection 1 is no longer connecting to the Internet when I switch to it.

Here is the dialog I'm struggling with on 18.04. As can be seen, it's different from the first image which is the dialog on both 14.04 and 16.04.

enter image description here

So how do I do it?

UPDATE: My intention is to connect the two computers together to arrange a fast transfer of files between them. Attempting to connect to the local network on the 18.04 machine throws an error Connection failed Activation of network connection failed.

As requested, the output of ps auxc | grep -i dns:

username 4032 0.0 0.0 382512 7448 ? Sl 09:41 0:00 gvfsd-dnssd

The output of ls -al /etc/resolv.conf:

lrwxrwxrwx 1 root root 39 Jun 2 07:59 /etc/resolv.conf -> ../run/systemd/resolve/stub-resolv.conf

And the output of cat /etc/resolv.conf:

nameserver 127.0.0.53
options edns0
  • Possible duplicate of How to connect two ubuntu computers with ethernet cable – Graham Jun 2 at 13:06
  • You can't use the same static IP connection profile to create your own local network, and use it for connecting to the general Internet. What is your goal? On the 18.04 machine, edit your question with the output from ps auxc | grep -i dns and ls -al /etc/resolv.conf and cat /etc/resolv.conf. – heynnema Jun 2 at 13:40
  • My goal is to connect the two computers in order to transfer files between them. Otherwise I'll update the question with the output of ps aux when I get back to the machines. – Duos Jun 2 at 13:52
  • @heynnema I've edited the question. Please check and advise. – Duos Jun 2 at 14:33
  • 1
    Rather than constantly swapping ethernet cables, and using different connection profiles, and moving your phone from USB on 16.04 and bluetooth on 18.04... how about something like this... connect the phone to 18.04... open nm-connection-editor and create a new ethernet profile... go to the IPv4 tab... enable "Share to other computers". Then on 16.04 create a standard ethernet connection profile with dhcp. Connect the cable. This should work without having to swap cables, or connection profiles, and having to move your phone. You may have to install dnsmasq-base to get this all to work – heynnema Jun 2 at 15:02
1

Brief outline for an alternate way to accomplish file transfers, without cable and connection profile changes, and more...

  • connect your phone to the 18.04 computer with bluetooth
  • on 18.04, open nm-connection-editor and create a new ethernet connection profile
  • go to the IPv4 tab and enable "Share to other computers"
  • go to the 16.04 computer
  • create a standard ethernet connection profile with dhcp
  • connect an ethernet cable between the two computers
  • note: you may have to reboot one/both computers at this time
  • enable Folder Sharing on one/both computers (use the Public folder if you wish)
  • transfer files using drag and drop
  • reach the Internet from either computer

note: you may have to install dnsmasq-base in 18.04 to get this all to work

  • When you bring up folder sharing, you're talking about NFS, which is actually the very first approach that I tried. But NFS doesn't work with encrypted directories, as I learned with my question unix.stackexchange.com/questions/522192/… – Duos Jun 2 at 15:27
  • I don't know how/if encryption effects this idea... that's a new twist... but with Folder Sharing, no explicit NFS mounts are required. Just get Properties on the PUBLIC folder, enable sharing. Eh... you might just try my idea and see what happens. Report back. – heynnema Jun 2 at 15:33
  • @Duos status please... – heynnema Jun 2 at 21:55
  • Ah, that was my upvote for providing me with valuable new information previously unknown to me. I now accept your answer as a solution that promises to work since I'm now at the last step -- enabling folder sharing. I'm having difficulties getting either Personal File Sharing or Samba (both being new to me) to work but no problem, I should be able to get through on my own. I'll then make another attempt with NFS (new to me also) and the Public folder. Many, many thanks, man. – Duos Jun 2 at 22:12
  • @Duos great news! Did you have to install dnsmasq-base? For folder sharing, just get Properties on the folder, and enable sharing there. – heynnema Jun 2 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.