5

I have problem with connecting to vpn my company gave me those files along with a password

openvpn folder

I tried to import them this way
1- I go to Network Setting
2- then I press the plus button to add new connection
3- then I choose import from file option
4- then I select the tw-proxmox-ovh_vpn.ovpn file
5- and finally I put the password and save

after this is I try to connect I get this message

error message

and if I check the syslog I find this error

enter image description here

I looked around in google and I found two ways

The first way is to use this command line each time I have to connect

sudo openvpn /home/pookyfox/Documents/tw-proxmox-ovh_vpn/tw-proxmox-ovh_vpn.ovpn

This way is so much boring each time open my laptop I have to and execute the command and put the password and leave the terminal open

The second way is to import network connection using this command line

sudo nmcli c import type openvpn file tw-proxmox-ovh_vpn.ovpn

The problem in this way is that if I connect to the network I get a success message but I only have access to the VPN not any other website (like google for example) and to resolve the I have to check this Use this network only for its resources on its network in the network setting in the IPv4 tab and my guess is that I have overridden some hidden setting when I save after checking that button.

And here's the OpenVPN configuration

client
proto udp
dev tun
ca ca.crt
dh dh2048.pem
cert tw-proxmox-ovh_vpn.crt
key tw-proxmox-ovh_vpn.key
remote [ip_adress] [port]
cipher DES-CBC
verb 2
mute 20
keepalive 10 120
comp-lzo
persist-key
persist-tun
float
resolv-retry infinite
nobind
tls-cipher "DEFAULT:@SECLEVEL=0"

I had to add the tls-cipher "DEFAULT:@SECLEVEL=0" because I had an other issue. So my question is how can I use network manager to connect to the VPN ?(just like the second way but with the box checked)

0

if it works with sudo..

try running

ll /home/pookyfox/Documents/tw-proxmox-ovh_vpn/

or

ls -o /home/pookyfox/Documents/tw-proxmox-ovh_vpn/

and check if your user/group has read/execute rights to those files. If you see something like these

drwx------   8 root root  ...
-rw-r--r--   1 root root  ...

but not like these

drwxr-xr-x   2 root root ...
drwxrwxrwt  17 root root ...
drwxr-xr-x  10 root root ...
-rwxrwxrwx   1 pookyfox pookyfox ...

just do a sudo chmod -R 777 /home/pookyfox/Documents/tw-proxmox-ovh_vpn/ and try to re-run them again.

Just throwing the first idea off the top of my head, hope it helps.

  • Thanks for your answer but i already have all the permission for those files, but it's just openVPN problem. I just need to right configuration to make it work through the GUI not the CLI – Neji Soltani Jun 8 '19 at 21:46
  • 1
    Oh I see, at first it seemed to me as if the app wasn't able to read the file. Well I would focus on that OpenSSL error then and if this link didn't help you in any way, then good luck:) – altinturk Jun 8 '19 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.