2

I am using Ubuntu 18.04 and everything was fine before moving to my new room and now I have a very slow internet connection here. The connection speed is ok on windows and my ios phone. my laptop model is Lenovo IP320 and the wireless card is Realtek Semiconductor rtl8821ce.

the result for nmcli dev wifi list is as follows:

IN-USE SSID MODE CHAN RATE SIGNAL BARS SECURITY * Vodafone Infra 11 405 Mbit/s 86 ▂▄▆█ WPA1 WPA

2

First, I recommend that you establish a baseline for signal strength. Please run the terminal command:

nmcli dev wifi list

Please take note of the Signal reading for your router. Now let's try a driver parameter:

sudo modprobe -r 8821ce
sudo modprobe 8821ce rtw_ant_num=1
nmcli dev wifi list

Is there any improvement in the signal? If not, try:

sudo modprobe -r 8821ce
sudo modprobe 8821ce rtw_ant_num=2
nmcli dev wifi list

I suspect that one of these settings will result in a noticeable improvement. Make the driver parameter permanent:

sudo -i
echo "options 8821ce rtw_ant_num=X"  >  /etc/modprobe.d/8821ce.conf
exit

...where X is the setting that you find offers the greatest improvement.

4
  • hi, the signal strength is full and I have tried everything but no luck :( – mani mohtasham Jun 2 '19 at 17:52
  • The signal strength is full, meaning high (??) and your connection is still slow. Is that what you are saying? Please clarify. – chili555 Jun 2 '19 at 23:30
  • yes, the signal strength is high but still my connection to the internet is very slow. I tried many suggested ways but nothing happened – mani mohtasham Jun 6 '19 at 22:11
  • Please edit your question to show the result of the terminal command: nmcli dev wifi list Thanks. – chili555 Jun 6 '19 at 23:15
1

I have experienced similar things, many ways and orders have been done but still slow. then I found a simple tip by removing the check mark on "make available to another users" https://i.stack.imgur.com/ejlrr.png

1
  • I tried but unfortunately nothing happened – mani mohtasham Jun 2 '19 at 17:49
0

With a rtl8821ae (lspci | grep Wireless)

Clone the repository

git clone https://github.com/lwfinger/rtlwifi_new.git

cd rtlwifi_new

Compile and install the drivers in own Linux

sudo make
sudo make install

Unload the adapter module:

sudo modprobe -r rtl8821ae

For a more permanent change to your adapters options you must create a driver configuration file. Create the following Realtek rtlwifi driver configuration file.

/etc/modprobe.d/rtl8821ae.conf

Copy and paste the following into the conf file:

options rtl8821ae swenc=1

options rtl8821ae ips=1

options rtl8821ae rtw_power_mgnt=0

options rtl8821ae rtw_enusbss=0

options rtl8821ae swlps=1

options rtl8821ae fwlps=1

options rtl8821ae debug=1

options rtl8821ae disable_watchdog=1

options rtl8821ae msi=1

Reload the adapter module.

sudo modprobe rtl8821ae

If this configuration doesn't work, you can test changing the values

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.