1

This is a long shot, since I doubt there are many Sun Microsystems Type 6 keyboards out there and probably even fewer users thereof, but here goes.

I've been using this keyboard for ages and the volume up and volume down keys have suddenly stopped working properly. I have swapped keyboards (I have several of these keyboards) and I have more or less determined that it is not a problem with the keyboard itself.

This problem is that when the Volume Up and Volume Down keys are pressed, two key press and two release events are generated:

key press   122 [XF86AudioLowerVolume]
key press   123 [XF86AudioRaiseVolume]
key release 122 [XF86AudioLowerVolume]
key release 123 [XF86AudioRaiseVolume]

Some other special keys also seem to be exhibiting odd behavior.

For instance, pressing Page Up generates:

key press   86 [KP_Add]
key press   112 [Prior]
key release 86 [KP_Add]
key release 112 [Prior]

and pressing Page Down generates:

key press   117 [Next]
key press   104 [KP_Enter]
key release 117 [Next]
key release 104 [KP_Enter]

Replacing the keyboard with a Sun Microsystems Type 7 produces correct keystrokes and if I can't solve this, I suspect I'll have to bite the bullet and switch keyboards. I'd rather not, since I like the "feel" of this keyboard (which is why I bought five of them when I had the opportunity).

In case it's relevant, I'm using the following little script, which I pinched from elsewhere in one of the Stack Overflow family of sites, to capture the keystrokes:

xinput list | \
    grep -Po 'id=\K\d+(?=.*slave\s*keyboard)' | \
    xargs -P0 -n1 xinput test | \
    awk 'BEGIN{while (("xmodmap -pke" | getline) > 0) \
        k[$2]=$4} {print $0 "[" k[$NF] "]"}'

evtest produces similar information. For instance, pressing the Volume Up key produces:

Event: time 1559427389.998130, -------------- SYN_REPORT ------------
Event: time 1559427392.390430, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70081
Event: time 1559427392.390430, type 1 (EV_KEY), code 114 (KEY_VOLUMEDOWN), value 1
Event: time 1559427392.390430, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70080
Event: time 1559427392.390430, type 1 (EV_KEY), code 115 (KEY_VOLUMEUP), value 1
Event: time 1559427392.390430, -------------- SYN_REPORT ------------
Event: time 1559427392.438435, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70081
Event: time 1559427392.438435, type 1 (EV_KEY), code 114 (KEY_VOLUMEDOWN), value 0
Event: time 1559427392.438435, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70080
Event: time 1559427392.438435, type 1 (EV_KEY), code 115 (KEY_VOLUMEUP), value 0
Event: time 1559427392.438435, -------------- SYN_REPORT ------------

If it's relevant, I'm running Ubuntu 19.04, to which I just upgraded today from 18.04 LTE in hopes that would cure the problem -- it didn't, obviously.

My guess, which admittedly is a wild one, is that some configuration that influences USB and/or HID drivers has changed or been updated but I'm currently at a loss to determine what or where that might be.

If there's some other diagnostic I should run, I'd appreciate a pointer thereto.

Clues greatly appreciated.

Followup (6/2/2019):

I just tested the keyboard on a fresh install of Ubuntu 19.04 on a different machine and I get the same failure mode. This was with two different Type 6 keyboards, so at this point I'm fairly convinced that it's some sort of driver issue and not a mechanical issue with the keyboard itself or with the particular installation of Ubuntu on a specific machine.

Second followup (7/29/2019):

After letting this lie fallow for a few weeks while I worked on another project, I finally got around to revisiting the issue and, lo and behold, the problem seems to have solved itself.

In the interval between the original posting early in June and today, near the end of July, of course there have been a couple of kernel updates, which I have dutifully installed, so perhaps something got fixed or changed in the interim.

I don't particularly like problems which "fix" themselves but in this case, I'll take what I can get.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.