0

I recently installed openssh on my old dell desktop pc for ease of access because I was going to use it as a media server. I used to be able to access it from my windows 10 laptop using putty but now I am unable to access it regardless if I type in my ip adress or the hostname.

I keep on getting the error"Network error:Network error connection refused" when typing in my ip adress I am able to type in my host name now but when I try typing my username at the login screen I get the error "No supported authentication methods available(server sent:publickey)

I am not sure what to do really so I finally decided to ask on the forums about this issue and what can be done in terms of solutions.

Typing in systemctl status sshd I get the following errors several times "Could not load host key"

"No supported key echange"

edit:resetting the host keys got rid of the errors when typing systemctl status sshd.

Typing - v gives me the error "Temporary failure in name resolution" so I will have to fix that

In terms of ubuntu version I am using ubuntu server 18.04.02 lts. I know this because that is where I downloaded the iso that I burned to my disk.

4
  • openssh (client) is usually installed on Ubuntu releases by default, so it was probably openssh-server that you installed (the client allows you to ssh to other boxes; server is needed to remotely ssh in). Have you tried using the verbose mode (ie. ssh -v) to see if you can get more clues? I'd also like the version of Ubuntu (it lets us know the age and options of tools you are using as they can change with later releases) – guiverc Jun 1 '19 at 22:34
  • I installed the latest version of ubuntu server. – Swedish ubuntugeek Jun 2 '19 at 0:39
  • Providing the actual release is more accurate; some people only count LTS releases so the latest to them is 18.04, and not 19.04. Have you tried -v or verbose output, and what did you see? Adding that to your question allows us to more accurately help you, as your question is vague & unclear. I just tried ssh -v to a server here, and see 48 lines of output before authentication succeeded message. This would be what I would look at in your position, but we cannot see that detail. – guiverc Jun 2 '19 at 1:27
  • Added some more info – Swedish ubuntugeek Jun 2 '19 at 10:24
0

There are two main SSH packages, one for client and the second one for server.

You're looking for openssh-server package.

sudo apt install openssh-server

Once it's installed your can check its status with:

systemctl status sshd

Always remember to secure your OpenSSH Server:

0

I fixed the issue myself by reinstalling ssh and adding my files to the server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.