5

I am having issues getting my second display to work properly in my latest install (Kubuntu 19.04). When I originally installed it, it would ask me (on startup) how to handle secondary display (See below) But my secondary display showed properly.

handle split display dialog

Now, for some reason, as you can see, image 1 is my hdmi output (works fine), and image 2 is the DVI monitor. The pictures actually make it seem better than it is. It's basically unusable. Fonts and small things (like icons and cursors) are the worst.

It almost looks like it can't anti-alias?

I've tried switching displays, it's not the monitor itself. swapping the cord causes the other monitor to do it. I've tried different cords also, same result. I would imagine it has to be my video card somehow, but I've not made any changes to it, or my configuration since I first built the machine (like a year ago). Have been using Windows mainly for the last little while, and decided to give Linux another go as my primary, and just VM to Windows when I need it.

When installing Kubuntu via my live usb, the display was fine. Seems to only affect the installed os.

xrandr output:

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 527mm x 296mm
   1920x1080     60.00 +  74.97*   50.00    59.94  
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x960      60.00  
   1366x768      59.79  
   1280x800      60.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    60.00    59.94  
   720x400       70.08  
DVI-D-0 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 527mm x 296mm
   1920x1080     60.00 +  74.97*   50.00    59.94  
   1680x1050     59.88  
   1600x1000     60.01  
   1440x1080     59.99  
   1400x1050     59.95  
   1280x1024     75.02    60.02  
   1440x900      60.00  
   1280x960      60.00  
   1280x800      60.00  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  

If I switch the display to the next highest resolution (1680x1050), it also looks fine, but I would much prefer to have both monitors on the same resolution.

There has to be some system configuration, because it's fine in Windows, and it's fine in the Linux Live environment.

Video card, if it ends up relevant is Radeon RX 550 640SP / RX 560/560X according to lspci | grep HDMI

(You'll see plain ubuntu in the screenshot, that's a vnc to another machine on my network, and took the best photos) HDMI 1920x1080

DVI 1920x1080

  • are you using a TV as a monitor plugged in as hdmi? 50 reputation points says you are. – tatsu Jun 7 '19 at 14:00
  • 1
    Nope -> both are Element 24" 1080p Monitor. And like I mentioned in my post. The display is fine in the linux live environment. – Nieminen Jun 7 '19 at 20:56
1

I noticed that if I re-installed Kubuntu, I'd get the proper display back. On the last install I did, I decided to look at my display settings again, and realized I didn't have a primary display set, so I used the KDE display settings ( Application Laucher > Computer > System Settings > Display & Monitor > Display ) to set my hdmi output to primary, which immediately caused the issue on the dvi output monitor. Setting back to no primary didn't fix it.

After this I tried setting some things that I hadn't considered before. Looking at the settings for the dvi display, I noticed that the refresh rate ( System Settings > Display & Monitor > Display; under Advanced ) was set to "auto". Simply setting it to 60.00 hz solves the issue.

| improve this answer | |
  • You should probably edit the answer to improve where the settings was and how you fixed it to 60hz, for example it could be with xrandr or it could be on the monitor, it's not clear in the answer. – pbhj Jun 10 '19 at 13:33
  • 2
    Hey thanks, I went ahead and added something. It's a little vague, I'll clean it up and make it more specific tonight after I get home. – Nieminen Jun 10 '19 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.