0

I have a dual boot setup installed in disks as follows:

  • 128GB SSD: Windows 10
  • 1TB HDD: 150GB Partition for Ubuntu 18.04.2 LTS + Remaining as D drive in Windows

I have disabled the "Fast Startup" option in Windows 10, which supposedly causes problems for mounting the hard drive.

This is my disk partition structure:

varshith@ghost:$ lsblk -f
NAME   FSTYPE  LABEL       UUID                                 MOUNTPOINT
loop0  squashf                                                  /snap/gtk-common
loop1  squashf                                                  /snap/gnome-logs
loop2  squashf                                                  /snap/core/6350
loop3  squashf                                                  /snap/spotify/35
loop4  squashf                                                  /snap/gnome-calc
loop5  squashf                                                  /snap/gnome-3-26
loop6  squashf                                                  /snap/gnome-char
loop7  squashf                                                  /snap/gnome-syst
sda                                                             
├─sda1                                                          
├─sda2                                                          
├─sda3 vfat                9265-0C62                            /boot/efi
└─sda4 ext4                2a060833-af29-49fc-8a50-546aad2d7250 /
sdb                                                             
├─sdb1 vfat    ESP         3298-9385                            
├─sdb2                                                          
├─sdb3                                                          
├─sdb4 ntfs                2C1A6EFF1A6EC604                     
├─sdb5 ntfs    Image       A436EFCC36EF9D94                     
└─sdb6 ntfs    DELLSUPPORT 2CB0C81BB0C7EA02

Here sda2 is the partition I would like to mount. I don't know why is it not being recognized as an NTFS partition. Does the BitLocker encryption has anything to do with this?

This is my disk structure as shown in Windows 10 Disk Management Tool

I have tried the following to get my D-drive part mounted on Ubuntu, and none of them were successful:

  1. I expected the drive to appear in Devices(or Other Locations) in the Nautilus file explorer automatically. (It used to happen in Windows7-Ubuntu dual boot in my previous system, a few years ago.)
  2. I tried to mount the disk manually:
varshith@ghost:/media$ sudo mount -t ntfs -o nls=utf8,umask=0222 /dev/sda2 /media/DATA
[sudo] password for varshith: 
NTFS signature is missing.
Failed to mount '/dev/sda2': Invalid argument
The device '/dev/sda2' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?`
  1. In Read-only mode (Note: ntfs-3g package is already installed):
varshith@ghost:/media$ sudo mount -t ntfs-3g -o ro /dev/sda2 /media/DATA
NTFS signature is missing.
Failed to mount '/dev/sda2': Invalid argument
The device '/dev/sda2' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
  1. I received a suggestion to run the check disk tool on that drive by logging into Windows OS. I did run the command CHKDSK on Windows Powershell which took more than an hour to complete. But again while trying to mount the disk, I'm getting the same error: NTFS signature is missing

Do note that I do not wish to format the sda2 partition since I have some required data and would like to just mount it to Ubuntu either in Read-Write mode or in Read-only mode.

7
  • Have you by any chance activated Dynamic Volumes in Windows? That's a Microsoft proprietary technology not supported in Linux.
    – user880592
    Commented Jun 1, 2019 at 10:14
  • 1
    You should run lsblk -f to show filesystem info. Commented Jun 1, 2019 at 10:19
  • @GabrielaGarcia No, I have not activated Dynamic Volumes in Windows. Also please check the Windows Disk Management tool snapshot.
    – Varshith
    Commented Jun 1, 2019 at 15:32
  • @mikewhatever I ran the lsblk -f command and have included the result in the question.
    – Varshith
    Commented Jun 1, 2019 at 15:33
  • 1
    Is bitlocker enabled on the drive in question?
    – vidarlo
    Commented Jun 1, 2019 at 15:39

1 Answer 1

1

The problem is with the BitLocker being enabled for the disk in discussion. Disable the BitLocker encryption by going to: Control Panel > System & Security > BitLocker Drive Encryption > Select - Turn Off BitLocker

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .