0

I'm running 18.04 on a formerly MS 64 bit system. I have Nautilus installed.

I tried to empty the trash bin from Nautilus (sudo nautilus to get to root level), it failed. Access denied.

I tried using sudo chown to take ownership, it told me it couldn't find the folder no matter what I tried (not in local shared, not desktop, nowhere).

I tried rm -rf and then dragging the folder into terminal, that didn't work either.

sudo -H nautilus gave me nothing. Trash folder nowhere to be seen, yet when I exit out it's still there and still full of root items I can do nothing with.

I've gone all through the questions on here looking for answers, and nothing has worked so far. I'm pretty frustrated. And I'm worried about screwing something up at this point. I don't know what sort of things you'll want to see from me, so I'll wait to be asked. That will be easier instead of pasting potentially useless things here.

1

Access denied is usually because there is some other program/something locking, and probably using, those files. Permission denied is what you get if you lack permissions.

The first thing you should try to do is rebooting your machine to make sure no other program is locking those files.

If that fails, and assuming we are dealing with a hard drive, instead of a removable media (like a pen drive, external hard drive, etc) a good solution would be simply booting into a live media. To do this you can use the media you used to install Ubuntu, and when prompted, instead of choosing Install Ubuntu, you should choose Try Ubuntu.

After that we want to mount your hard drive to access the files. It will probably appear on your file manager, but if it doesn't show up there, you can mount it with:

udisksctl mount --block-device /dev/sdXY     

You have to substitute both the letters X and Y from the command above with the correct ones from your drive. You can see the drive you want to choose with lsblk. If your drive is using LUKS/Full disk encryption, you will want to unlock it before mounting.

udisksctl unlock --block-device /dev/sdXY     

After mounting, navigate to the location of the trash folder, which is usually /home/USER/.local/share/Trash/ and attempt to remove it with sudo rm -rf. So something similar to this, again, making sure you substitute the USER with the proper user whose trash you wish to delete.

sudo rm -rf /home/USER/.local/share/Trash/
  • I'll give this a try tonight when I have a little more time - it's errand day today. I've got 18.04 on a flash drive. Hopefully, this works. – Jade Autumn Jun 1 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.