0

I tried to set up a x64 18.04.2 xubuntu on a windows 10 pro host machine using the VM Player 7. Installing xubuntu works fine. The Vmtools however are not able to set up the shareable folders between the host and the guest machine. This is how I tried it:

VM Player > Manage > Install VMWare tools. After extraction I ran the sudo ./vmware-install.pl -d command in the folder's terminal. I put the Log messages down below. As the logs are very long I only put in the error messages.

I tried to sudo apt-get install gcc-8 as suggested in another thread on this topic. Is there anyone that can help me get this running? I also tried sudo apt-get install gcc. And yes I did sudo apt update as well. I'm very new to linux systems so don't hesitate pointing out the obvious.

Thank you guys very much.

Logs:

The VMware Host-Guest Filesystem allows for shared folders between the host OS 
and the guest OS in a Fusion or Workstation virtual environment.  Do you wish 
to enable this feature? [yes] 


(process:9380): GLib-CRITICAL **: 10:19:16.043: g_file_test: assertion 'filename != NULL' failed

(process:9406): GLib-CRITICAL **: 10:19:16.276: g_file_test: assertion 'filename != NULL' failed

(process:9417): GLib-CRITICAL **: 10:19:16.507: g_file_test: assertion 'filename != NULL' failed

WARNING: This program cannot compile any modules for the following reason(s)...

- This program could not find a valid path to the gcc binary.  Please ensure 
that the gcc binary is installed on this sytem.

[ Press Enter key to continue ] 
  • Do the tools need gcc-8 specifically? if not, the easiest way is likely to install the default gcc package for your system - which will install gcc-7 and symlink it to /usr/bin/gcc – steeldriver May 30 at 8:37
  • @steeldriver I do not need gcc-8 specifically. I'm very new to linux, how do I symlink? – Dennis Hügle May 30 at 8:41
  • If you do not need gcc-8 specifically, then you don't need to worry about doing the symlink yourself - just install the gcc package (or the build-essential metapackage) and apt will take care of everything for you – steeldriver May 30 at 8:45
  • @steeldriver: This is what I thought, I did it via sudo apt-get install gcc, however this leads to "gcc is already the newest version (4:7.4.0-1ubuntu2.2)." in the terminal and not changing the error message when trying to install the vmtools. (Edit: Accidential Sent) – Dennis Hügle May 30 at 8:48
  • Sorry I missed that you already tried that - so does /usr/bin/gcc exist? what is the output of type -a gcc? what happens if you type gcc --version? – steeldriver May 30 at 8:55
0

Much thanks to @steeldriver for the help provided. What solved the problem for me is to go back on an earlier release of xubuntu. In my case 1404 solved it (I didnt try out any other xubuntu versions in between, so maybe those work as well. I still have the 1804 machine running if someone comes up with an other idea.

Cheers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.