0

I have a WD Passport Wireless Pro drive, not officially supported for Ubuntu. I got it working on Ubuntu 18.04 via USB connection after installing a mounting package. From there I would see a "drive detected" screen and the folder would appear inside /media/.

Now none of this happens. Does anyone know the packages needed to mount external drives? I think they might need a reinstall.


Output after running dmesg

 34.900070] usb 3-1: new high-speed USB device number 4 using xhci_hcd
[   40.156141] xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
[   40.822262] Adding 15624188k swap on /dev/sda5.  Priority:-2 extents:1 across:15624188k FS
[   45.133660] audit: type=1400 audit(1559189664.128:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/snap/core/4917/usr/lib/snapd/snap-confine" pid=821 comm="apparmor_parser"
[   45.133666] audit: type=1400 audit(1559189664.128:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/snap/core/4917/usr/lib/snapd/snap-confine//mount-namespace-capture-helper" pid=821 comm="apparmor_parser"
[   45.168725] audit: type=1400 audit(1559189664.164:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/man" pid=824 comm="apparmor_parser"
[   45.168730] audit: type=1400 audit(1559189664.164:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_filter" pid=824 comm="apparmor_parser"
[   45.168733] audit: type=1400 audit(1559189664.164:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_groff" pid=824 comm="apparmor_parser"
[   45.200508] audit: type=1400 audit(1559189664.196:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=826 comm="apparmor_parser"
[   45.200514] audit: type=1400 audit(1559189664.196:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd" pid=826 comm="apparmor_parser"
[   45.200517] audit: type=1400 audit(1559189664.196:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd//third_party" pid=826 comm="apparmor_parser"
[   45.200535] audit: type=1400 audit(1559189664.196:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/tcpdump" pid=829 comm="apparmor_parser"
[   45.214845] audit: type=1400 audit(1559189664.208:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/lightdm/lightdm-guest-session" pid=819 comm="apparmor_parser"
[   45.532067] xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
[   45.740102] usb 3-1: device not accepting address 4, error -62
[   45.868044] usb 3-1: new high-speed USB device number 5 using xhci_hcd
[   50.908144] xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
[   56.284080] xhci_hcd 0000:00:14.0: Timeout while waiting for setup device command
[   56.492129] usb 3-1: device not accepting address 5, error -62
[   56.492232] usb usb3-port1: unable to enumerate USB device
[   56.620034] usb 3-4: new high-speed USB device number 6 using xhci_hcd
[   56.770149] usb 3-4: New USB device found, idVendor=058f, idProduct=6366
[   56.770152] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   56.770154] usb 3-4: Product: Flash Card Reader/Writer
[   56.770155] usb 3-4: Manufacturer: Generic
[   56.770157] usb 3-4: SerialNumber: 058F63666485
[   58.235449] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   58.235451] Bluetooth: BNEP filters: protocol multicast
[   58.235457] Bluetooth: BNEP socket layer initialized
[   62.204983] usb-storage 3-4:1.0: USB Mass Storage device detected
[   62.205263] scsi host6: usb-storage 3-4:1.0
[   62.205366] usbcore: registered new interface driver usb-storage
[   63.229333] scsi 6:0:0:0: Direct-Access     Multiple Card  Reader     1.00 PQ: 0 ANSI: 4
[   63.229934] sd 6:0:0:0: Attached scsi generic sg2 type 0
[   63.581907] usbcore: registered new interface driver uas
[   63.938534] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[   69.272434] kauditd_printk_skb: 40 callbacks suppressed
[   69.272445] audit: type=1400 audit(1559189688.268:52): apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/sys/devices/system/node/" pid=1063 comm="mysqld" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
[   70.865804] audit: type=1400 audit(1559189689.860:53): apparmor="DENIED" operation="capable" profile="/usr/sbin/mysqld" pid=1063 comm="mysqld" capability=2  capname="dac_read_search"
[   72.092400] audit: type=1400 audit(1559189691.088:54): apparmor="DENIED" operation="capable" profile="/usr/sbin/mysqld" pid=1063 comm="mysqld" capability=2  capname="dac_read_search"
[   73.375077] audit: type=1400 audit(1559189692.368:55): apparmor="DENIED" operation="open" profile="/usr/sbin/mysqld" name="/sys/devices/system/node/" pid=1178 comm="mysqld" requested_mask="r" denied_mask="r" fsuid=116 ouid=0
[   73.792837] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[   73.795965] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[   74.085961] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[   74.619309] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[   75.715327] NET: Registered protocol family 4
[   75.719103] NET: Registered protocol family 5
[   77.154342] aufs 4.15-20180219
[   89.159552] audit: type=1400 audit(1559189708.152:56): apparmor="STATUS" operation="profile_load" profile="unconfined" name="docker-default" pid=1632 comm="apparmor_parser"
[   90.196758] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[   90.202383] Bridge firewalling registered
[   90.209477] nf_conntrack version 0.5.0 (65536 buckets, 262144 max)
[   90.591651] Initializing XFRM netlink socket
[   90.599509] Netfilter messages via NETLINK v0.30.
[   90.601155] ctnetlink v0.93: registering with nfnetlink.
[   90.855664] IPv6: ADDRCONF(NETDEV_UP): docker0: link is not ready
[   91.373324] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
[ 4859.898700] perf: interrupt took too long (2541 > 2500), lowering kernel.perf_event_max_sample_rate to 78500
6
  • 1
    Do other external drives not work or just this one? USB devices and basic filesystems are baked into the kernel, so I'd be more inclined to suspect a cable issue than a package. The obvious exception would be exfat. What happens if you do tail -f /var/log/syslog and then plug in the drive? It may show you the error. If you get no error then maybe there's a partition issue. You can also try gnome-disks. May 30, 2019 at 4:51
  • Running that command has revealed another issue with an old vpn service continually restarting and mucking up the log, so I will have to work on that now. I don't have another external drive to test unfortunately
    – Sean D
    May 30, 2019 at 6:18
  • 1
    Did you ever tried to do dmesg command in a terminal just after you plug-in the drive? How is formatted the drive? If it is FAT/NTFS formatted did you ever tried to insert it in a Windows Pc to see if it needs a check?
    – ciampix
    May 30, 2019 at 7:13
  • It is exfat4. I have pasted the output of dmesg above, it does look like it detects but has an error
    – Sean D
    May 30, 2019 at 8:31
  • Have you tried this drive connected to another machine? WD put hardware encryption interfaces on a lot of their MyBook and MyPassport products. If the interface fails, the data on a healthy disk is unreadable. If the drive has the same problem connecting to another computer then it might be a problem with the encryption chip. This happened to me with a MyBook and it was a major PITA to recover the data.
    – VanAlbert
    May 30, 2019 at 8:38

0

You must log in to answer this question.

Browse other questions tagged .