36

I'm getting an error that I've never seen before when running sudo apt update. The error happens after reaching http://dl.google.com/linux/chrome/deb stable/main amd64 Packages. I haven't done anything recently that I know of that could have suddenly caused this error to happen.

Here is the full output of sudo apt update:

➜  ~ sudo apt update                                    
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://packages.ros.org/ros/ubuntu bionic InRelease                                                                                                                                               
Hit:3 http://us.archive.ubuntu.com/ubuntu bionic InRelease                                                                                                                                              
Hit:5 http://packages.microsoft.com/repos/vscode stable InRelease                                                                                                                                      
Get:6 http://dl.google.com/linux/chrome/deb stable Release [943 B]                                                                           
Get:7 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]                                                                        
Get:8 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]                                                                                             
Get:9 http://dl.google.com/linux/chrome/deb stable Release.gpg [819 B]                                                                                                             
Get:10 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1,104 B]                                                                                                  
Err:10 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages         
  File has unexpected size (1103 != 1104). Mirror sync in progress? [IP: 172.217.11.78 80]
  Hashes of expected file:
   - Filesize:1104 [weak]
   - SHA256:77ca2eefc7975f403bc1c9fb2dd97ed4a010d9c0b3f7932f07dd7995fc7c67a1
   - SHA1:9c0534b7034652963231d629283e83833f706121 [weak]
   - MD5Sum:14dd8b71c35111b40f1f06c565349097 [weak]
  Release file created at: Wed, 29 May 2019 17:35:47 +0000
Hit:4 https://packagecloud.io/slacktechnologies/slack/debian jessie InRelease   
Fetched 178 kB in 1s (219 kB/s)                    
Reading package lists... Done
E: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/main/binary-amd64/Packages.gz  File has unexpected size (1103 != 1104). Mirror sync in progress? [IP: 172.217.11.78 80]
   Hashes of expected file:
    - Filesize:1104 [weak]
    - SHA256:77ca2eefc7975f403bc1c9fb2dd97ed4a010d9c0b3f7932f07dd7995fc7c67a1
    - SHA1:9c0534b7034652963231d629283e83833f706121 [weak]
    - MD5Sum:14dd8b71c35111b40f1f06c565349097 [weak]
   Release file created at: Wed, 29 May 2019 17:35:47 +0000
E: Some index files failed to download. They have been ignored, or old ones used instead.

I've read in other places that removing the entry from my software update sources will get rid of the error. But wouldn't that mean I would no longer get updates for Google Chrome? I would think there must be a better solution than that.

Searching for this error through Google, I couldn't find this exact error happening with google chrome stable main for anyone else. I'm curious to know if this is a temporary issue with the server?

I am running Ubuntu 18.04.2 on a desktop machine.

7
  • 7
    I would just wait a couple minutes (hours at most) and then try again. File has unexpected size (1103 != 1104). Mirror sync in progress? sounds like a temporary repository server problem that should go away on its own.
    – Byte Commander
    May 29, 2019 at 22:16
  • 2
    I saw it earlier this morning, and just tried again (same issue & about 50 mins from prior attempt), but I'm just taking it as another google stuff up, that they'll fix when they get around to it, so I'm just ignoring it for now. I'm on 19.10, and I think it applies to all releases.
    – guiverc
    May 29, 2019 at 22:23
  • 2
    Not sure, I am not really familiar with that specific message. A mirror sync, as your local apt client suggests, is what maintainers of repo mirror servers do to update their mirror from a central server by copying all the updated files over. During this process, there could be inconsistencies. I have no idea if this is really what is happening here or not though, just freely interpreting the hint apt gives.
    – Byte Commander
    May 29, 2019 at 22:32
  • 2
    I'm getting the same exact message right now, suggesting this is actually something on the mirror's side that will be resolved in time. I'm going to just try again tomorrow.
    – Ben Lee
    May 29, 2019 at 23:22
  • 2
    @ByteCommander may have been right...the problem on my end at least seems to have resolved itself...
    – sfletche
    May 30, 2019 at 1:52

8 Answers 8

15

The several users who called it as being a repository server problem seem to have been right.

Even several hours after first seeing the error and after plenty of reboots the error wouldn't go away yesterday.

Today, however, the error is gone. I can now run apt update without any problems. Thanks everyone for saving me many hours of pointless debugging. :)

6

You can use the following commands.

sudo apt-get clean clears out the local repository of retrieved package files

sudo apt-get update downloads the package lists from the repositories and "updates" them to get information on the newest versions of packages and their dependencies.

sudo apt-get clean
sudo apt-get update
1
  • Thank you Mohammad, this solved my problem (MX linux)
    – Mossab
    Jan 11 at 1:27
3

On Ubuntu 18.04 system you can list and remove PPA using Software & Updates application. Start Software & Updates application , navigate to Other Software tab and Remove or Edit any highlighted PPA repositories:

2
  • 3
    I know that this is a way to "fix" the error, but I don't want to remove the repository for Google Chrome as that would mean I could no longer get Chrome updates.
    – chimbo
    May 29, 2019 at 23:13
  • remove the old repository and add the new repository for google chrome wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add - && sudo sh -c 'echo "deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list' May 31, 2019 at 7:09
1

Issue seems to be from google ppa side. You can remove the ppa temporarily using the following command:

sudo rm /etc/apt/sources.list.d/google-chrome.list

this will disable updates from google ppa. to add it back you can follow instructions in this link

1

This a new feature coming to 20.04? Most likely 19.10 as well. I build Operating Systems and maintain repositories.

Err:16 http://os-builder.com/Apps Apps/all i386 Packages                                                                               
  File has unexpected size (33042 != 31876). Mirror sync in progress? [IP: 173.XXX.XXX.XXX 80]
  Hashes of expected file:
   - Filesize:31876 [weak]
   - SHA512:84ad69c54ca63e9df15567b4793396ef24b0c1a9383d26ab6c45dfd910b9b4f53c230e8f5a00d319cce8dc0c69f704069d5e6e5f22c4b8ca6adc92d546898e5a
   - SHA256:73fa3568d6086ac3205fc8a9348564327dc2acaccfa7ba9eb5e8f8d212118dac
   - SHA1:20cdc8139dc51f991428751c5e3f0d89bdd3a11e [weak]
   - MD5Sum:2a54810993925cf4fa327024d8395500 [weak]
  Release file created at: Fri, 24 Apr 2020 05:36:02 +0000

I did have to create a new file called "InRelease" and GPG sign the file inline. All the files are uploaded so that is not the real issue.

    -----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Origin: Ultimate Edition
Label: Apps
Suite: Apps
Version: 1.0
Codename: Apps
Date: Fri Apr 24 01:36:02 EDT 2020
ARCHitectures: i386 amd64 armhf
Components: all
Description: Apps Repository automatically generated via Repostorm http://repostorm.com
Date: Fri, 24 Apr 2020 05:36:02 +0000
MD5Sum:
 8b342ed3f4bb2ff74f0690da759d76fc              286 Release
 8d3c4be5c461f6b2e9685d380c493d80           139512 all/binary-amd64/Packages
 443ce074133e3604eed5fdbb6cc0e092            33042 all/binary-amd64/Packages.bz2
 f3423eb342ca96697f70d3b763b014b0            38796 all/binary-amd64/Packages.gz
 5d7e2cc2446c4772cd3a797d44adc03f           140659 all/binary-armhf/Packages
 55cf4dcd31ee2cba2bdab4df38c24878            33090 all/binary-armhf/Packages.bz2
 9faf3c43498727b09578ea29f297b1d6            38441 all/binary-armhf/Packages.gz
 580043fcc721c67a85c5134b8fa28c9a           136613 all/binary-i386/Packages
 2a54810993925cf4fa327024d8395500            31876 all/binary-i386/Packages.bz2
 6f4663bc015d3a7590569c91d67e30ed            37453 all/binary-i386/Packages.gz
SHA1:
 58058a195ca88d2fa91d72a5093741579a1cd383              286 Release
 4938b1d7760aef38d0cd62879eb4c5c0ebf2c32d           139512 all/binary-amd64/Packages
 4a7f5245a3b0f7a56a46626e518c67d79cea4e26            33042 all/binary-amd64/Packages.bz2
 684620e07e80c79713f8a1018173e98faaa5f79f            38796 all/binary-amd64/Packages.gz
 51bd1b4343d9365eafa003817d18fbc885e3da35           140659 all/binary-armhf/Packages
 6534b630cbac4f65700bbf24503e79df8ef55ab1            33090 all/binary-armhf/Packages.bz2
 2ec02da9917651bdb59d02a8840e114612170d25            38441 all/binary-armhf/Packages.gz
 230614a95792375f109ad118fcb2c5aa9ce45b6e           136613 all/binary-i386/Packages
 20cdc8139dc51f991428751c5e3f0d89bdd3a11e            31876 all/binary-i386/Packages.bz2
 3bfd451f4f53b7f87dcdf752c29818b1932779bd            37453 all/binary-i386/Packages.gz
SHA256:
 5f14088d56b9385f1ecf7d76e2db658129bb04199f7eb3efb7c368b8e75082c0              286 Release
 659b69d5a37ab6ea063f935bf830a901882b4279260e7547c31c5a799bc07ac2           139512 all/binary-amd64/Packages
 4ae52f85c844ffcb6d244eabbde9321764803c830e42690536db0fe9ee48549b            33042 all/binary-amd64/Packages.bz2
 16b2a7c6e28c675c37894989846b6745b9e07b607d287b0f3b0868ce413f68b7            38796 all/binary-amd64/Packages.gz
 57e16407447ef660ee5e4aa54f19d1ad0c00a3df59bd373d8997bf8a85832a52           140659 all/binary-armhf/Packages
 85f1795516fbb93dbad53cda3d37d9af77772a2895aa4b2e2c4ef9aacc527139            33090 all/binary-armhf/Packages.bz2
 d5ffe480b9d7785e1eaefbe4f1d175e05e8fe404eda1c5d6a9a8ead592f68ab5            38441 all/binary-armhf/Packages.gz
 3cf46bcfe159517eebefdb9ade6be54e40dfca47ace880139cc0b41027f60a82           136613 all/binary-i386/Packages
 73fa3568d6086ac3205fc8a9348564327dc2acaccfa7ba9eb5e8f8d212118dac            31876 all/binary-i386/Packages.bz2
 322cc8fbaa9cee5a43b3c9fb8c8d14f537fde139aaa7a1f11a2f9af3ad840daa            37453 all/binary-i386/Packages.gz
SHA512:
 460eda22c59da4ae203fdd2e35b301797fa48e6cb8315528669ca841b1062b873784de171d2f34de9c328806247ab413cb641071a1fa386a95df563989cd72ac              286 Release
 862e4da10bb57d4853775f94ad1f05e66c3328457e15865cfe75c2add4683ad5ce4378e9574bc06703f368ab7d120cb9f27894406ec15c291064b8df56352ca1           139512 all/binary-amd64/Packages
 946fb297654f167a08adef11cdad8d6c8aaa27f7af0d9c612c4082dd00ac3dc2a541b45cfd2097ea8f52a55cd15a640bab2bb617d4aa64a1df04ba4b8f2cb719            33042 all/binary-amd64/Packages.bz2
 0fd86bf07477eac390f668241ce1ca1eb12efc44a4dc3bae95662107c8b70602c3f091ef44cdb90f7c81fb5b4a85e1d90e818330b2d3a28dc901bd58d733015c            38796 all/binary-amd64/Packages.gz
 2ce106d65a3576d2f9f66c2ee8a67ef453b90bdda108e67f477726994bda42d291514219d02c7721c3ca3b0e4d1403e16633e2cb1e9acb70f0ace20036856816           140659 all/binary-armhf/Packages
 12dde31094baa0f7aa5a41430e807263ea78daa9723ba9d78ef5f04d882e9df5d6d1ebe95b36fdaf73ce75fd626d82e3f0dbdf198d06cc2b7380cbb551879a7a            33090 all/binary-armhf/Packages.bz2
 cdcbbba3035a2e7011c798cabc168d05d2a0f0dd62222c8442f0599f83558e1d4abc8058b93fd3440c6fed16fd896d554edc5ad0fca847c165eeacd347955ffb            38441 all/binary-armhf/Packages.gz
 f24ed8e5091d3a28adbedc885cd3da37fc923d60cc0ddba456149029f2aa64987b87b19df35c231265ae9d0fc99ee314a6a1cf9ac4a295e3869d04913476ba42           136613 all/binary-i386/Packages
 84ad69c54ca63e9df15567b4793396ef24b0c1a9383d26ab6c45dfd910b9b4f53c230e8f5a00d319cce8dc0c69f704069d5e6e5f22c4b8ca6adc92d546898e5a            31876 all/binary-i386/Packages.bz2
 4dc11df12a3e2dcc1dad138ae3e5a47616615b89ff6f86d4c42e0a4ea643718297049abb86633b1f57cbf737c906d7fa34093651af1f9589c5f1642c337a942b            37453 all/binary-i386/Packages.gz
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEGATuABSuVlbVW6YsT3oitqdE21kFAl6ietMACgkQT3oitqdE
21lcBwf/S/to2flkBCSnCXWcffcn4iGiB3dNyraabuH+pYNC/lmEXidvyw69eiOq
o+j8l+EqTIus8BL9gsCsBB7br4VmQKsB/MgxJ63TZBZ0hYnc/WfS0zYu+CaNoEOi
+vh2UisUTJrVdzWM8UCYAYgYVFXkz70sIAzYqzgeM6CzTerQMiQUKotRt1aMBE24
kbaAt/RNCZA6dh5p5lPEaaLWmQawvdB/YN9To1HSoJnJqbYgJm6IZ7yDQoUc4LRx
nyn9tZjgM/hD2MdSVX7Vml0xXCiR+rozXt2al5ygZ/lauJrzcVHwa0viNs5xA6kt
9FBUhLc40tXpAixijKSQEK5f0E/B5Q==
=XSwh
-----END PGP SIGNATURE-----

Evidently not good enough. I am still looking for the actual solution.

Right under my nose:

Get:7 http://os-builder.com/Apps Apps InRelease [5293 B]
Get:14 http://os-builder.com/Apps Apps/all amd64 Packages [33.0 kB]
Get:16 http://os-builder.com/Apps Apps/all i386 Packages [31.9 kB]

I note no problems with AMD64, all are i386. Any package that are "all" architectures are symbolically linked to "AMD64" where the actual files reside this makes it so I do not have to upload the file twice (is all arch's right). So, in essence I will have to physically create a "InRelease" file via each architecture. I hope I helped someone & at least I hope you understand how repositories work.

1
  • I'm hitting the same wall. Apr 28, 2020 at 21:48
0

Issues is your existing PPA. You need to remove first existing PPA using below command and freash install Google chrome thru this link.

sudo rm /etc/apt/sources.list.d/google-chrome.list

Once installation completed you will check your PPA entry here. It will automatically be updated through your Software Update tool.

$ cat /etc/apt/sources.list.d/google-chrome.list
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
0

I had the same issue on Linux Mint. I solved the issue with the following command:

sudo rm -rv /var/lib/apt/lists/*
0

I had the same issue.

Solution: Try connecting to a different network.

Network providers sometimes have security software running which redirects any ftp page that doesn't contain a path to a warning page.

So connecting to my mobile cellular data fixed the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .