4

For example I cannot switch between the tabs in gnome-terminal with Alt+1, Alt+2 anymore. Shortcuts in general and Menu shortcuts specifically, are enabled via the global gnome-terminal settings.

When I hit Alt + 1 it looks like this.

enter image description here

And it's the same behaviour without tmux: enter image description here

I already opened an issue in the gnome-terminal repo, but it was rejected. It really decreases the usability of the gnome-terminal for me.

I'd be happy to find any solution to that, even if it requires a bit of effort.

5
  • I also upgraded my notebook from 18.10 to 19.04 several weeks ago, but Alt+1, Alt+2, etc. do work in my gnome Terminal. Did you check Shortcuts in Preferences of Terminal? – FedonKadifeli May 29 '19 at 9:54
  • @FedonKadifeli Yes, they are set. – anarchist912 May 29 '19 at 12:01
  • Output of sudo update-alternatives --config x-terminal-emulator: 169/5000 There is only one alternative in link group x-terminal emulator (which provides / usr / bin / x-terminal-emulator): /usr/bin/gnome-terminal.wrapper Nothing to configure. – anarchist912 May 29 '19 at 12:10
  • 1
    Same here, just upgraded to 19.04. Shortcuts also set in preferences. – Breno Salgado May 30 '19 at 13:36
  • I have the same problem and replaced all shortcuts to Ctrl+[n] – Ramin Firooz Jul 16 '19 at 8:08
8

The Alt-# shortcuts start working again when I disable "Enable mnemonics" for some reason. The menu shortcuts don't work with the menu bar hidden anyway, so I don't miss that setting.

5
  • 1
    Where can you disable that? – anarchist912 Oct 12 '19 at 21:41
  • 1
    Oops, it's in Preferences under General. – Ari Oct 13 '19 at 22:15
  • Seems contradictory to deactivate something to make it work, but who know's what genius puzzled that out. Switching tabs with Alt+1, Alt+2, etc. works only when I don't enable shortcuts (re-translated from German UI). – anarchist912 Oct 21 '19 at 11:59
  • it has fixed my problem as well! Thanks – Adriano Tadao Sep 7 '20 at 14:59
  • 1
    For posterity - this also happens when upgrading to Ubuntu 20.04, and this solution fixed it for me. Thanks! – Ben Harper Sep 26 '20 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.