1

this is my first question here. (Though I'm no stranger to Linux/Ubuntu)

I just set up a second display with my desktop running Ubuntu 18.04 with the most recent stable drivers. The display is not being detected through the settings panel, but it is showing up when I run xrandr --query as "not disconnected but has no modes" (I'll append the full output below)

I am using a DisplayPort to HDMI dongle to connect the monitor in question to my Graphics Card (MSi AMD Radeon RX560). Could that be the issue? Also the second display is technically a TV if that matters.

Thanks!

xrandr: Output

DisplayPort-0 is not disconnected but has no modes
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DisplayPort-0 connected (normal left inverted right x axis y axis)
HDMI-A-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 476mm x 268mm
   1920x1080     60.00*+  50.00    59.94  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x960      60.00  
   1280x800      60.00  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    60.00    59.94  
   720x400       70.08  
DVI-D-0 disconnected (normal left inverted right x axis y axis)
1

It says that DisplayPort-0... ... has no modesthis means that nothing has been reported to the OS and it as such can't determine for example the resolution.

A solution to this would be to add a resolution to your output. ArchWiki always has great guides on these things and are compatible with Ubuntu generally.

And this chapter of the wiki show how to do it permanently because xrandr changes are temporary.

I personally currently have three monitors connected to my RX580 (one with a active DP to VGA adapter) without any problems. If you have the components you could try to switch your adapter (active/passive) or even port to see if it is correctly detected so we could further find out what the underlying problem might be.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.