1

if I try to install gnutls-dev it will install the libgnutls28, but in the system I do have libgnutls30. How can I install the dev files for gnutls30?

Note, selecting 'libgnutls28-dev' instead of 'gnutls-dev'
  • yes, as I showed the message. It says selecting libgnutls28-dev instead. – Wang May 28 '19 at 18:45
  • Package libgnutls-dev is not available – Wang May 28 '19 at 18:49
0

Not sure if you solved this already but wondering the same thing myself, however...

If you install gnutls:

$ sudo apt-get install gnutls-bin
$ ...
$ Setting up gnutls-bin (3.5.18-1ubuntu1.3)
$ ...

Then if you check the dev package:

$ apt-cache show libgnutls28-dev
$ ...
$ Package: libgnutls28-dev
$ Architecture: amd64
$ Version: 3.5.18-1ubuntu1.3
$ ...

Seems to be up to date with the installed version. I'm not up on the naming scheme but 28 doesn't seem to be behind or anything so might be fine for you. Should be okay for me at least.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.