0

I read some places that you can just install Docky using apt by default but that doesn't work. Tried adding the repository, but it's one of those that won't update because it's unauthorized or something. Is there a repo that works with Ubuntu 19.04 for Docky?

EDIT: @user535733

> $ sudo add-apt-repository ppa:docky-core/stable [sudo] password:
> This ppa is currently used for builds of release builds of
> docky and plank.  More info:
> https://launchpad.net/~docky-core/+archive/ubuntu/stable Press [ENTER]
> to continue or Ctrl-c to cancel adding it.
> 
> Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease Hit:2
> http://archive.canonical.com/ubuntu cosmic InRelease                  
> Hit:3 http://us.archive.ubuntu.com/ubuntu disco InRelease             
> Hit:4 http://dl.google.com/linux/chrome/deb stable Release            
> Hit:5 http://us.archive.ubuntu.com/ubuntu cosmic InRelease            
> Get:6 http://security.ubuntu.com/ubuntu disco-security InRelease [97.5
> kB]      Hit:7 http://us.archive.ubuntu.com/ubuntu disco-updates
> InRelease               Hit:8 http://us.archive.ubuntu.com/ubuntu
> cosmic-updates InRelease              Ign:9
> http://ppa.launchpad.net/docky-core/stable/ubuntu disco InRelease     
> Hit:11 http://us.archive.ubuntu.com/ubuntu disco-backports InRelease  
> Err:12 http://ppa.launchpad.net/docky-core/stable/ubuntu disco Release
> 404  Not Found [IP: 91.189.95.83 80] Reading package lists... Done    
> E: The repository 'http://ppa.launchpad.net/docky-core/stable/ubuntu
> disco Release' does not have a Release file. N: Updating from such a
> repository can't be done securely, and is therefore disabled by
> default. N: See apt-secure(8) manpage for repository creation and user
> configuration details.

You know, just you're usual can't update repo error.

  • "doesn't work" and "unauthorized or something" don't tell us enough to give you useful advice. We cannot see what you are seeing unless you show us the command and the full output. To copy-and-paste terminal output into your Question is very easy. – user535733 May 28 '19 at 18:43
  • 3
    Possible duplicate of What can I do if a repository/PPA does not have a Release file? – Kulfy May 28 '19 at 20:16
1

The docky-core PPA doesn't have a disco release. Their most current is artful. Change your .list file in /etc/apt/sources.list, or in /etc/apt/sources.list.d/, or look for another, more currently supported PPA.

Update #1:

In terminal...

cd /etc/apt # change directory

grep -i docky sources.list # search for docky

If it finds docky, then:

sudo pico sources.list # edit the file

Locate the line that contains docky

Change disco to artful

control+o, then return # to save the file

control+x # exit the editor

You're done.

If it didn't find docky, then:

cd sources.list.d # change directory

grep -i docky *.list # search again for docky

Note the filename when it finds docky

sudo pico found_filename.list # edit that filename

Change disco to artful

control+o, then return # to save the file

control+x # exit the editor

You're done.

  • What do I add in sources.list? I'm not too familiar with how to configure that. – Daniel Archuleta May 29 '19 at 20:37
  • Almost there, I changed it from disco to artful, and the repos updated successfully, but now when I run "sudo apt install docky" it says "Unable to locate package docky". Any ideas? – Daniel Archuleta May 31 '19 at 3:30
  • Ok, so I changed it to xenial and now it says i have unmet dependencies which can't be installed. Maybe it's hopeless. Thanks for the help anyway, I appreciate it! I learned something new in the process at least! – Daniel Archuleta May 31 '19 at 3:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.