2

I'm stuck trying to install Ubuntu, I can use the live desktop but when I go to install it just never gets past the Updates and Other Software screen. The cursor spins and I've left it a good hour but nothing happens. I've successfully installed using the same USB drive on my laptop but my desktop won't have it.

I've tried minimal install, normal install, with 3rd party options and without. I've made sure secure boot isn't enabled too.

I've also tried Budgie with also gets stuck at the same place.

Specs:

i5-3570 16gb RAM GTX 970

1tb HDD 5X 120GB SSDs (not RAIDed)

Is there anything I can try?

  • can you post the screenshot of where your installation hangs? – waqar May 28 '19 at 7:29
  • I can't post it here from my phone because of the file size but here's the screen where it hangs: imgur.com/a/5VIg197. - I know that's Budgie but it's the same screen in regular Ubuntu too – MisterM May 28 '19 at 7:59
3

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1766978

It's to do with this bug here.

When the installer got stuck, I opened Disks and mounted/unmounted the Windows partition a few times until it got to the next screen. Had to manually set up partitions because Ubuntu didn't detect Windows but it's all installed now.

| improve this answer | |
3

I opened gparted and saw there was a NTFS partition which was corrupted, that's why the installer didn't proceed. I deleted that partition and the installer worked flawlessly.

| improve this answer | |
0

while installing dont connect to the internet and uncheck 'download updates while installing budgie', probably its taking time because its downloading updates....you may download the updates after the installation is finished

| improve this answer | |
  • Because there's no network connection, the update box is greyed out – MisterM May 28 '19 at 9:35
0

I can confirm a solution similar to what Gabriel posted - but in my case, neither disks program nor gparted was able to actually delete the corrupted partition at the beginning. I had to actually delete partition from the terminal (using one of the terminal commands that deletes) and then the terminal hung. When I closed terminal and then opened up conventional program...I was able to work with the partition. The original corruption occurred because I had installed a previous linux distribution that screwed up the partition so it would not delete in a conventional way.

| improve this answer | |
0

For my case, when I cancelled the installation, I was directed to use Ubuntu on the live bootable flash disk.

  1. I opened the terminal and run

    # fdisk -l
    

to list all detected hard disks.

Here is a picture of the Terminal window: fdisk -l output

  1. Then I decide to format my hard drive because it had no important data.

    # mkfs.ext3 /dev/sda
    
  2. I ran the installer again and it worked.

Here is a picture of the Terminal window: mkfs output

| improve this answer | |
  • why not ext4? ext3 has far less features and is much slower link – kanehekili May 12 at 22:10
  • True, I realize ext3 was slow. I was being specific to what worked for me. – stephen mwaura May 13 at 7:28
0

Let's say if you have windows partition which you don't want to format and you are getting this error while trying to install latest ubuntu flavors, try to start the installer from boot in safe graphics mode. Then try to install. The "updates and other softwares" screen might hang for 10 mins, but after that you should see disk partition screen, here do the partition appropriately as per your choice. This worked for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.