2

Not knowing Linux has full Wacom tablet support, I thought I found out how to install a driver to enable the buttons on my Bamboo tablet, and I disabled my keyboard and touchpad.

I have the history.log entry for what I did, how do I undo this mess?

Start-Date: 2019-05-25  21:18:05

Commandline: apt-get install xorg-input-abi-24

Requested-By: lynda (1000)

Install: libxfont2:amd64 (1:2.0.1-3~ubuntu16.04.3, automatic), xserver-xorg-core-hwe-16.04:amd64 (2:1.19.6-1ubuntu4.1~16.04.2)

**Remove**: xserver-xorg-input-all:amd64 (1:7.7+13ubuntu3.1), xserver-xorg-input-synaptics:amd64 (1.8.2-1ubuntu3), xserver-xorg:amd64 (1:7.7+13ubuntu3.1), xserver-xorg-video-vesa:amd64 (1:2.3.4-1build2), xserver-xorg-video-nouveau:amd64 (1:1.0.12-1build2), xserver-xorg-video-amdgpu:amd64 (1.1.2-0ubuntu0.16.04.1), xserver-xorg-core:amd64 (2:1.18.4-0ubuntu0.8), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1build5), ubuntu-desktop:amd64 (1.361.3), xserver-xorg-input-wacom:amd64 (1:0.32.0-0ubuntu3), xserver-xorg-input-vmmouse:amd64 (1:13.1.0-1ubuntu2), xserver-xorg-video-vmware:amd64 (1:13.1.0-2ubuntu3), xserver-xorg-input-evdev:amd64 (1:2.10.1-1ubuntu2), xserver-xorg-video-all:amd64 (1:7.7+13ubuntu3.1), xserver-xorg-video-ati:amd64 (1:7.7.0-1), xorg:amd64 (1:7.7+13ubuntu3.1), xserver-xorg-video-radeon:amd64 (1:7.7.0-1)

End-Date: 2019-05-25  21:18:23

I tried dpkg in recovery mode after enabling network support but I got a lot of 522 errors and not all of the packages could be fixed and it said the update was aborted. (The ethernet cable was plugged in. ^_^')

0

Try booting into a tty-shell (press Ctrl+Alt+F2 on login-screen).

From there run

sudo apt remove xorg-input-abi-24
sudo apt autoremove
sudo apt install xserver-xorg xserver-xorg-core xserver-xorg-input-all ubuntu-desktop  xserver-xorg-video-all xserver-xorg-input-synaptics xserver-xorg-input-kbd xserver-xorg-input-wacom

That should undo the involuntary un-install of packages.

Note that Ubuntu should have wacom support out-of-the-box (xserver-xorg-input-wacom should be pre-installed on the desktop version of Ubuntu).

2
  • Pretty sure it's the dumbest thing I've ever done! Having trouble getting to the tty-shell with ctrl + alt + F2. I don't have a login-screen, I just have a black screen until the desktop loads. (Tried it after the Dell post screen, tried it during the black screen, no luck.)
    – LyNac
    May 28 '19 at 1:23
  • It worked! Everything's back to normal and I'll never try to add a driver for something I don't need again! Thanks so much!
    – LyNac
    May 28 '19 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.