0

I am trying to execute CMake in a C++ project which uses Tcmalloc.

The vm is new and I tried to install first

sudo apt-get install libgoogle-perftools-dev

Which upon other things it installed libtcmalloc-minimal4

Reading package lists... Done 
Building dependency tree        
Reading state information... Done 
The following additional packages will be installed:
   libgoogle-perftools4 liblzma-dev libtcmalloc-minimal4
   libtcmalloc-minimal4 (2.5-2.2ubuntu3) ... 
Setting up

But cmake still produces the following warning:

 -- Not Found Tcmalloc: Tcmalloc_LIBRARY-NOTFOUND

I also executed

dpkg -l | grep tcmalloc

 ii  libtcmalloc-minimal4      2.5-2.2ubuntu3      amd64      efficient thread-caching malloc

xUbuntu version:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.2 LTS
Release:    18.04
Codename:   bionic

Do I miss any other step or install any other package? Do I have to create any symbolic link in /usr/lib?

  • Have you tried cmake with the extra options such as cmake -DHPX_WITH_MALLOC=system as shown here? Also please share which version of Ubuntu is this. – S_whynot May 27 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.