4

i'm working in a project that, after compiling it, i have to launch with qemu.

When i type make qemu i have this error. I've search but i'm unable to find an answer.

I have install qemu with sudo apt install qemu-system-i386

Any helps?

2 Answers 2

6

SDL was becoming more and more unsupportable. The old 1.2 got out of date and many projects had various bugs adopting the newer 2.0 (that happened to QEMU).

So after Ubuntu 18.04 Ubuntu (and Debian) we switched away from it. These days SDL isn't even in main anymore. The alternative graphical backend - that also mostly works much better and gets more usage/fixes is GTK.

Use: qemu-... -display gtk

3
  • seems not to work Jun 1, 2019 at 12:15
  • Any more details than that to further help you? Jun 5, 2019 at 5:09
  • fix with commeting this line SET(EMULATOR_FLAGS ${EMULATOR_FLAGS} -sdl) in cmakelist Jun 5, 2019 at 12:15
0

Alternatively, you can compile qemu-system-i386 with forced SDL support by doing:

./configure --enable-sdl --with-sdlabi=2.0
make

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .