Firefox and Youtube videos were working after upgrading from 10.04 to 10.10 but a couple of weeks ago, my Youtube flash video player shows up as a grey box. The sound still works and I can hear the clip playing, but I can not see the video, or even the controls.

This is true for many of the flash based video players, and I think it even happens to some of the flash games out there on Firefox.

Everything works fine on Chromium. This isn't that weird because Chromium has its own flash plugin. However, some flash players still function properly on Firefox, like the full episode flash player on thedailyshow.com

Why would flash be grey box for some flash players but not all?

I have a 32bit system, and a ATI x300 GPU card, which has been giving me problems right after updating to 10.10, but that seems to be resolved now. I selected the allow proprietary codecs stuff at install , and then installed the Adobe Flash PPA and plugin in Ubuntu Tweak.

  • the ppa in ubuntu-tweak is for 64-bit.
    – RolandiXor
    Commented Nov 5, 2010 at 6:34
  • There is both a 64 bit and a 32 bit package. The 64 bit wouldn't be able to install if he had tried. Commented Nov 8, 2010 at 13:08

7 Answers 7


I would advise removing the Ubuntu Tweak PPA from your software sources by opening the Software Centre then clicking Edit->Software Sources.... Click the 'Other Software' tab then untick the Ubuntu Tweak PPA.

Close the software sources window and it should refresh your software index.

Uninstall any flash plugins you have installed then install ubuntu-restricted-extras. This should get flash working again.

In the future do not use PPAs unless you are certain of what you are doing. Note that Ubuntu Tweak is for users who know what they are doing and can mess up your system if you use it without precautions.

  • tried purging Ubuntu Tweak and it's PPAs already. didn't solve the problem. besides, i thought the flashplugin-installer in ubuntu-restricted-extras installs adobe's plugin? if it installs open-source flash, why would they bother putting it into restricted-extras?
    – hansioux
    Commented Nov 5, 2010 at 15:19
  • flashplugin-installer installs Adobe's proprietary flash plugin.
    – dv3500ea
    Commented Nov 5, 2010 at 15:22
  • i removed flashplugin-installer, and turned on firefox, got to youtube and it told me my plugin is missing, and when i clicked install missing plugin, instead of adobe one, i clicked gnash, restarted firefox, and now it's working. kind of strange. as usual, gnash eats up a lot of resources (eats up 45%+ CPU,) but at least it's working... so i guess i can't complain...
    – hansioux
    Commented Nov 5, 2010 at 16:08
  • You will get better results (unfortunately) with the proprietary adobe flash plugin than with gnash. Just stick to the official repositories and you should be fine.
    – dv3500ea
    Commented Nov 5, 2010 at 16:31

The problem lies with RGBA, if you have that enabled/installed. Try running firefox from the terminal, with this command:

export XLIB_SKIP_ARGB_VISUALS=1 && firefox


I had the same problem with flash on my 64-bit Kubuntu box. Blocking cookies from YouTube within firefox fixed the problem for me. I hope it helps.

You will have to delete the already installed youtube cookies, of course, for this to work.



This will painlessly give you the latest Flash. 64 or 32 bit.


I usually find that all I need to do when flash turns into a grey box is scroll up or down a little.

It's been some time since flash did that the last time though.

I have no clue why it works for me, but give it a try.


Finally I gave up, I just reinstalled Ubuntu 10.10. It was a clean install, and the problem was gone. Though it solved the problem, but unfortunately I have no idea what caused the issue, and I guess now I never will.


You could try removing the closed-sourced ATI drivers. I find that they cause more problems then they're worth, especially if your card is already supported by the opensource driver.

sudo apt-get remove fglrx*

should do the trick.

  • yes, it removed something called fglrx-modaliases and the issue was resolved. i don't even remember how that got there.
    – hansioux
    Commented Nov 5, 2010 at 15:14
  • hmm, now the embedded youtube videos work, but the flash player on the main site still shows grey box...
    – hansioux
    Commented Nov 5, 2010 at 15:27
  • Strange, FGLRX is the ATI closed sourced drivers. It was giving me all sorts of problems, so I stuck with using the opensource ones. I wish I could tell you why firefox is giving you a grey box. You could try updating flash, if you haven't already.
    – amanthethy
    Commented Nov 5, 2010 at 18:55
  • 1
    Also, I agree with dv3500ea. You should remove the Flash PPA you got from Ubuntu Tweak and just stick with the ubuntu-restricted-extras package.
    – amanthethy
    Commented Nov 5, 2010 at 18:56
  • I did that, still the same. But i noticed something interesting about my youtube grey box. If I click where the "full screen" button was supposed to be, it switches to Full Screen mode and everything works fine. The controls shows up, and the video shows up. I just have to full screen every vid to be able to see them. Without the full screen mode, still just grey box.
    – hansioux
    Commented Nov 7, 2010 at 9:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .