5

I recently dual booted ubuntu (with windows 10). My computer has a nvidia geforce graphics card and that has been the root of my problems with ubuntu for the past few weeks. I have the proper nvidia drivers installed yet I still get stuck at a purple screen sometimes when I try to login. The keyword being sometimes. Typically my first attempt at logging in gets met by a purple screen after I choose to boot ubuntu through the grub. Then after it freezes on the purple screen, and I am forced to shutdown my computer by holding the power button and restart it. This second time around I press e on the ubuntu option and enter into a block of code. There I press the up and down keys and delete and retype a few words and then type control x to boot. Note that I have not added any extra parameters such as "nomodeset" or removed anything. Then the majority of the time it magically boots and I am able to login. Note that a black screen does appear and some text is written but it boots successfully. Of course sometimes this does not work and I'm forced to enter recovery mode (which also freezes half the time) and try to fix the issue (typically by purging nvidia and reinstalling the exact thing I just purged -.- again this does not work all the time).

Any ideas on what's happening? This is pretty ridiculous. I don't want to force shutdown my computer 5 times before being able to login -.-

This is what the screen flashes when I login successfully and restart immediately after: 1

  • Ubuntu 18.04.2 LTS
  • Nvidia Geforce MX150
  • nvidia-driver-390 (proprietary)
  • Here is the output from cpu-z
  • Secure boot is disabled already
  • The open source driver nouveau is the default one I believe, so yes I had that one first. But then i got the purple screen with it so i installed the nvidia drivers
  • I checked asus for uefi updates here. There is only one: version 300.
  • My computer is a "ASUS ZenBook Flip 14 UX461FN."

When running "sudo apt install xubuntu-desktop lightdm" I get:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
xubuntu-desktop: Depends: xorg but it is not going to be installed
                 Depends: xubuntu-core but it is not going to be installed
                 Recommends: xserver-xorg-input-synaptics
E: Unable to correct problems, you have held broken packages.
  • Start by updating UEFI. Then check its settings for some "OS selection" menu or similar. Adjust accordingly (it won't affect Windows). Also Secure Boot should be disabled as it prevents loading the Nvidia drivers. – user880592 May 26 '19 at 21:37
  • Secure boot is disabled already. – LTM May 26 '19 at 22:08
  • What are your: 1. Ubuntu release, 2. Nvidia graphics and 3. Nvidia drivers version? – user880592 May 26 '19 at 22:19
  • 1. Ubuntu 18.04.2 LTS 2. Nvidia geforce MX150 3. Im using nvidia-driver-390 (proprietary) – LTM May 26 '19 at 22:29
  • does the problem persist when you uninstall nvidia and use the open source driver nouveau ? – AlexOnLinux May 29 '19 at 6:46
3
+500

There is an unsolved problem of another MX150 laptop that takes 10 minutes to boot in Windows.

There is a bug report filed against the ASUS Zenbook here:

Comment #47 seems to have the solution:

For anyone having a similar problem, try booting with microcode updates off: add dis_ucode_ldr to the kernel command line (from GRUB if you cannot boot)

To do this use:

sudo -H gedit /etc/default/grub

Find the line containing quiet splash and make it read quiet splash dis_ucode_ldr whilst keeping everything else on the line the same.

Save the file and type:

sudo update-grub
reboot

Hopefully it all works fine now. If this is your situation make sure to subscribe to the bug report.

  • Works now. Thanks! Is there any detriments to booting with microcode updates off? – LTM Jun 9 '19 at 4:09
  • 1
    @Akash I did some searching but couldn't find any concrete examples of disadvantages to turning it off. I would track the bug report though and as soon as it is fixed turn microcode updates back on. – WinEunuuchs2Unix Jun 12 '19 at 10:39
0

Maybe, it is stupid suggestion, but it might be the fault of display manager. Try changing to different flavor and different display manager, for example:

sudo apt install xubuntu-desktop lightdm
sudo dpkg-reconfigure lightdm

And in login screen, choose Xubuntu. Also, I will suggest changing Prime profile to power saving mode:

sudo prime-select intel

To revert to the original state, do:

sudo dpkg-reconfigure gdm3
sudo prime-select nvidia

And in login screen, choose your older flavor.

Hope this works.

  • Before I try this, how would I go about reverting it just in case? – LTM Jun 8 '19 at 0:46
  • @Akash, edited the answer to include reverting methods. – Olimjon Jun 8 '19 at 0:48
  • "sudo apt install xubuntu-desktop lightdm" gives an error (updated in post). – LTM Jun 8 '19 at 23:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.