1

I have a Laptop Pavilion HP 2000, and it have dual boot on Linux Mint (Tessa) and Windows 10.

For some strange reason, the wifi led on the fn keys shows the wifi as disabled, and pressing it doesn't change the color of the led (from amber meaning off to white meaning on). I don't know how to resolve it.

rfkill list all shows this

0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: yes

And after pressing the corresponding fn key (fn + F12) it changes to this

0: phy0: Wireless LAN
 Soft blocked: yes
 Hard blocked: yes

Somehow, instead of trying to unlock via hardware, it is locking it and unlocking via software.

More information about my system here (lscpi and other commands output there)

I already verified that the wifi is not blocked by some way on the BIOS (It doesn't even have functions related to any kind of network there). And already reset the Bios like a lot of forums suggest it. Also, unplugged the battery and pressed the power button, and tried to press the wifi button while the computer is booting. Nothing worked.

I think it's important to say that in Windows 10 the wifi is working properly, but it is completely ignoring the led ambar (i think it just ignores the Hard block).

Another thing that i found interesting it's that i tried with a live usb of manjaro (latest version) and it also can't connect to the wifi.

The internet is working properly trough an Ethernet connection, actually, I'm posting this on the laptop that is failing.

Any kind of information will be appreciated. Thanks in advance.

1
  • Although Mint is off-topic here, I have proposed an answer because the answer is quite the same for Ubuntu.
    – chili555
    May 26 '19 at 16:23
1

The issue of HP wireless being inoperable because of a hard block and therefore the usual wireless key not toggling wireless on and off is long-standing. There are only a few things you can try.

First, try removing the helper module hp_wireless and then try to switch the wireless on with the key combination.

You could also try:

sudo modprobe -r hp_wireless
sudo rfkill unblock all
rfkill list all

Second, check the user guide for your HP laptop and be certain that the wireless key combination you are using is correct. Be certain that you are not using Fn+F12, for example, if the user guide says it is simply F12. On the other hand, if you are certain you are using the correct sequence, try the wrong sequence as an experiment; i.e., use Fn+F12 (or whatever your sequence is) if the user guide says it’s F12 and vice versa.

Next, you can remove the card, tape off pin 20 and re-insert it: https://ubuntuforums.org/showthread.php?t=2150597

You can, if all these steps fail, file a bug report against the module hp_wireless: https://bugs.launchpad.net/ubuntu/

Finally, in many, but not every case, a USB wireless will also be hard blocked for the same reasons. If you want to try one, be certain to try it within a return period.

I regret that there isn’t a better answer for HP laptops.

Possibly related: Why does "Airplane Mode" keep toggling on my HP laptop in Ubuntu 18.04?

3
  • I tried different ways of enabling/disabling hp_wmi and hp_wireless via modprob. And didin't worked, also, i tried to download and install the corresponding drivers but i could not compile them. As last resource i tried the trick with the pin 20 of the wifi card, and.... didn't worked.
    – thblckjkr
    May 26 '19 at 22:24
  • I'm just giving up. I will use an USB antenna, but first disabling the rt2800pci via modprobe blacklist.
    – thblckjkr
    May 26 '19 at 22:26
  • As I said, I regret there isn’t a better answer. Sorry.
    – chili555
    May 26 '19 at 23:08
0

Wlan BCM4311 hard blocked

sudo apt purge bcmwl-kernel-source
sudo apt install firmware-b43-installer
sudo modprobe -rfv b43
sudo modprobe b43
rfkill list all

disconnect your lan cable

Now it works

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.