0

I am quite sure my Lenovo Thinkpad L570 has a Gigabit (1000 Mb/s) Ethernet interface. So why does the wired Network Settings say Link Speed 10 Mb/s? (Speedtests often say more than 200 Mb/s upload and download.) OK. Here comes the output of "$ sudo lshw -C network":

  *-network
       description: Ethernet interface
       product: Ethernet Connection (4) I219-LM
       vendor: Intel Corporation
       physical id: 1f.6
       bus info: pci@0000:00:1f.6
       logical name: enp0s31f6
       version: 21
       serial: 98:29:a6:7d:c9:bf
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.1-4 ip=192.168.0.163 latency=0 link=yes multicast=yes port=twisted pair speed=10Mbit/s
       resources: irq:129 memory:f2700000-f271ffff

I presume "size: 10Mbit/s" corresponds to the line "Link speed 10 Mb/s" in Ubuntu Network Settings.

9
  • 1
    You can install ethtool and then run ethtool on the port in question and it should show you what your link speed is. – Terrance May 25 '19 at 19:29
  • I could show it to you if askubuntu.com had an option for uploading a screen shot. – Henrik R. May 25 '19 at 19:32
  • 1
    Edit your question and show me sudo lshw -C network... this will show your link speed... and if you're only getting 10Mb then you've probably got a cable problem. Describe your wiring from the Thinkpad to the modem/router. – heynnema May 25 '19 at 19:44
  • 1
    @HenrikR. It's because that kind of data doesn't belong in the comments, but rather, as an edit to your original question. Paste the text, select the text, click the {} icon to format the text. Then you can delete your last three comments. Remember to describe your cabling for me. – heynnema May 25 '19 at 19:53
  • I guess the line "size: 10Mbit/s" corresponds to what is showed as "Link speed 10 Mb/s" in Settings. – Henrik R. May 25 '19 at 19:54
1

sudo lshw -C network shows us that you've only got a 10Mb link on your ethernet port. Your ethernet card can handle 1Gb, so you're really losing a lot of speed.

98% of the time this indicates a cable problem. You need to be using a cat 5E or cat 6 cable. Try replacing your cable and then recheck lshw. 1% of the time it means that the ethernet card is not auto-negotiating the link correclty. Another 1% is due to a router problem with its LAN ports.

Update #1:

Power cycling the router and the computer solved the problem.

Update #2:

There's still a partial problem. Try connecting/disconnecting the laptop DIRECTLY to the router and/or DSL/cable modem. Retest. Check the settings in the router to make sure the LAN port that your using for the laptop is set to 1G (as opposed to auto). Retest. Use ethtool to force your laptop to use 1G instead of auto-negotiate. Retest.

Update #3:

  ethtool -s devname [speed N] [duplex half|full] [port tp|aui|bnc|mii]
          [mdix auto|on|off] [autoneg on|off] [advertise N] [phyad N]
          [xcvr internal|external] [wol p|u|m|b|a|g|s|f|d...]
          [sopass xx:yy:zz:aa:bb:cc] [msglvl N | msglvl type on|off ...]

sudo ethtool -s enp0s31f6 speed 1000 duplex full autoneg off

Now shows...

sudo lshw -C network

*-network 
    description: Ethernet interface 
    logical name: enp0s31f6 
    size: 1Gbit/s  <=== correct value
    capacity: 1Gbit/s 
    width: 32 bits 
    clock: 33MHz 
    configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.1-4 ip=192.168.0.163 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s resources: irq:129 memory:f2700000-f271ffff
16
  • OK. I changed the cable from the laptop to the router to another Cat 5E cable, and ran "sudo lshw -C network". It still says " size: 10Mbit/s". Should I try resetting or power off the router? – Henrik R. May 25 '19 at 20:27
  • 1
    @HenrikR. just to be clear, you have a cat 5E cable that goes to a wall plate, and then a cat 5E cable from the wall plate to the router, yes? Yes, UNPLUG the router from AC, shutdown the computer, plug in router, wait 30 seconds, boot computer. If it still shows 10Mb, do one of two things... connect a cat 5E cable from the computer DIRECTLY to the router and recheck. If that doesn't work, enter the router's admin page and make sure the LAN ports are set to 1Gb. – heynnema May 25 '19 at 21:30
  • Shutting down and powering off both the laptop and the router solved the "Link Speed 10 Mb/s" problem. Now it's back to "Link Speed 1000 Mb/s". And speed tests confirms that things work. PS: There is a Cat 5E from the laptop to the router and a Cat 6 from the router to the wall. – Henrik R. May 26 '19 at 12:29
  • Thank you for your help! But the problem is only 50% solved, in the sense that if I disconnect the cable to the Ubuntu Lenovo L570 laptop and connect it again, the settings show "Link Speed 10 Mb/s" again, and then I have to shut down everything again... – Henrik R. May 27 '19 at 9:58
  • @HenrikR. Try the other things that I mentioned earlier. Try connecting/disconnecting the laptop DIRECTLY to the router and/or DSL/cable modem. Retest. Check the settings in the router to make sure the LAN port that your using for the laptop is set to 1G (as opposed to auto). Retest. Use ethtool to force your laptop to use 1G instead of auto-negotiate. – heynnema May 27 '19 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.