0

I had install libboost-all-dev python-mako python-docutils python-numpy on buntu 16.04.6 LTS, but always return unable to locate.

I have tried sudo aptitude install, it also can not work. And i also did sudo add-apt-repository universe but it still could not find the package.

I had tried to regenerate /etc/apt/sources.list and sudo apt-get update, but still not work.

$ sudo apt-get install libboost-all-dev python-mako python-docutils python-numpy
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package python-numpy is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package python-docutils is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  docutils-common

E: Unable to locate package libboost-all-dev
E: Unable to locate package python-mako
E: Package 'python-docutils' has no installation candidate
E: Package 'python-numpy' has no installation candidate
$ cat /etc/apt/sources.list
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://archive.ubuntu.com/ubuntu xenial main restricted
deb-src http://archive.ubuntu.com/ubuntu xenial multiverse main universe restricted #Added by software-properties
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu xenial universe
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu xenial multiverse
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu xenial partner
deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://archive.ubuntu.com/ubuntu xenial-security main restricted
deb-src http://archive.ubuntu.com/ubuntu xenial-security multiverse main universe restricted #Added by software-properties
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://archive.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://archive.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
deb http://archive.ubuntu.com/ubuntu xenial-updates multiverse universe main restricted
deb-src http://archive.ubuntu.com/ubuntu xenial-updates multiverse universe main restricted #Added by software-properties

New sources.list file only containing standard sources,

$ cat /etc/apt/sources.list
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
# deb http://archive.ubuntu.com/ubuntu xenial main restricted
# deb-src http://archive.ubuntu.com/ubuntu xenial multiverse main universe restricted #Added by software-properties
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
# deb http://archive.ubuntu.com/ubuntu xenial multiverse
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb-src http://cn.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.

# deb http://archive.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://archive.ubuntu.com/ubuntu xenial-security multiverse main universe restricted #Added by software-properties
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
# deb http://archive.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
deb http://archive.ubuntu.com/ubuntu/ xenial main restricted universe multiverse  
deb http://archive.ubuntu.com/ubuntu/ xenial-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu xenial-security main restricted universe multiverse  
deb http://archive.canonical.com/ubuntu xenial partner 
# deb-src http://archive.ubuntu.com/ubuntu xenial-updates multiverse universe main restricted #Added by software-properties
  • The results ofcat /etc/apt/sources.list have been added, have you any idea to correct this? – donghai huang May 25 '19 at 12:37
  • 1. Get rid of any conflicting software sources in /etc/apt/sources.list by commenting them out by prefacing them with a # character. You can add them back later by removing the # characters from the start of the lines where you added them. 2. Don't forget to run sudo apt update to refresh the list of available packages. – karel May 25 '19 at 12:43
  • Thanks for your reply. But i am not so clear with conflicting software sources, can you point it out ? – donghai huang May 25 '19 at 12:49
  • To begin with all you need are the standard Ubuntu 16.04 sources.list which is already listed in the link. Everything else you can comment out to begin with and add them back by uncommenting them later. Don't forget to run sudo apt update afterwards to refresh the list of available packages. – karel May 25 '19 at 12:51
  • 1
    Thanks karev, i got the reason. The command sudo apt update did not work, because the prior installation of JetPack, which lead a failure Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/main/binary-arm64/Packages 404 Not Found [IP: 91.189.91.23 80]. Thanks again. – donghai huang May 25 '19 at 13:48
1

The libraries cannot be located because of the failure by command sudo apt update, which caused by my prior installation of JetPack.

When running command sudo apt update, it outputs,

Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/main/binary-arm64/Packages 404 Not Found [IP: 91.189.91.23 80]

And i fixed it by

sudo apt-get purge ".*:arm64"
dpkg --remove-architecture arm64

Then after updating source by sudo apt update, everthing was fixed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.