9

I use Ubuntu Studio 18.04.2, 64 bit Linux (with the extended support) Operating System.

I don't know why but, today one of my desktop PCs doesn't have pulseaudio working.

I tried: pulseaudio -k, first and then: pulseaudio -D but, I just got the messages:

Fail to stop the daemon because it is not working.
Fail to start the daemon.

So I went to Synaptic Packages Manager and I uninstalled, first, and then I reinstalled all about pulseaudio

But it doesn't work.

It doesn't start at startup.

Even more, I tested if I had sound from some apps (audacity, musescore, firefox) and... Nothing! There is no sound!

I have the exactly same Linux OS in my 3 PCs (two desktops and one laptop) and this issue is just present in one of my desktop, only, since today!

I don't know what to do to rescue the pulseaudio daemon!

What's wrong here?

What can I do to fix this?

BTW: If it could possible..., Can we use ALSA only? How can we switch between pulseaudio and ALSA at any time?

6
  • Have you checked your hardware? ie. I'd boot a 'live' system (ideally something other than the a Ubuntu [Studio] 18.04 you are using) to check that the issue is related to your config, and not just your hardware?
    – guiverc
    Commented May 24, 2019 at 23:29
  • Not. It is not about my hardware. It is something about some missed modules which are not present in the pulseaudio config of that PC. Some of those missed modules are: module-jackdbus-detect, module-bluetooth-policy, module-systemd-login. But, I don't have any clue about how to re-install them, because they are not in Synaptic Packages Manager and we can not to install them, with sudo apt-get install. So...
    – Juan
    Commented May 25, 2019 at 20:12
  • More reason to me to try booting 'live' systems. If you find a 'live' system that boots & works as you want, you can list modules (lsmod) etc to find out what works with your actual hardware, then replicate that setup on your chosen installed system. It's what I do frequently. The other choice is given you know when it started occuring; I often find files that were modified in the -mtime (or files newer than the last boot when it worked etc) to look for a change that caused it. This may be more difficult now given you've purged & re-installed packages causing lots of changes.
    – guiverc
    Commented May 25, 2019 at 22:20
  • I got audio from all apps! After a lot of reinstallations, I got audio again! But... Now I have to manually write: pulseaudio -D to start the daemon. So... I don't know how to perform a real final fix to this issue!
    – Juan
    Commented May 26, 2019 at 5:11
  • 1
    I think I found the reason for this rare behaviour, but I don't have any clue why... I discovered that in the Starting and Sessions option (in the Configuration Manager) the command: pulseaudio -D was included into the startup apps panel. I unclicked it and, now... All is working so fine!!! I suspect some app made this change, but I don't know which, or when.
    – Juan
    Commented May 27, 2019 at 20:43

6 Answers 6

15

For me, on Ubuntu 20.04, the solution was as easy as doing:

systemctl --user enable pulseaudio

followed by:

systemctl --user start pulseaudio

(this will fail, obviously, if you started pulseaudio manually via pulseaudio --start, so in this case to try the user unit simply issue a pulseaudio --kill followed by the above)

Last but not least you can do systemctl --user status pulseaudio to see what the current status is (but typically you see that in the status icon for volume controls).

None of those commands require superuser access. Tested and verified on Ubuntu 20.04 with KDE (not Kubuntu!).

For additional troubleshooting advice I warmly recommend having a look into the Arch Wiki.


Please be aware that the potential alternative:

systemctl --user disable pulseaudio.socket

... did not work for me at all.

1
  • 1
    This appears to create a symlink in the home directory Created symlink /home/jmunsch/.config/systemd/user/default.target.wants/pulseaudio.service → /usr/lib/systemd/user/pulseaudio.service which makes sense for me, because I had recently moved a bunch of files around including my home directory config folder, so i think i bork the symlink
    – jmunsch
    Commented Jun 14, 2021 at 15:39
2

try maybe using:

killall pulseaudio 

And try Again with:

pulseaudio --start

If it started up, But has some weird static effect, then try Doing either:

killall pulseaudio

OR

pulseaudio -k && sudo alsa force-reload && sleep 2 && pulseaudio -k && sudo alsa force-reload
0

In my case, I have a encrypted home folder that prevent pulseaudio from starting. I got this message: "Failed to create secure directory (/home/ubuntu/.config/pulse): No such file or directory"

The solution was to edit "sudo systemctl edit sound.target" And to put:

[Unit]
BindsTo=home.mount
After=home.mount
0

For me, this was solved by updating preinstalled PipeWire to use ppa version. You can follow the installation instructions here to see if it helps: https://linuxconfig.org/how-to-install-pipewire-on-ubuntu-linux

0

Reinstall pulseaudio using sudo apt install pulseaudio

0

As guiverc advised me, I think I found the solution to this:

  1. Go to the Configuration panel
  2. Go to the Starting and Session option.
  3. Look for the tab: Startup Apps
  4. Check if there is something related with Pulseaudio

In my specific case, I found a direct command:

pulseaudio -D

activated.
I unchecked it, and... Everything was fixed!
So...

1
  • 3
    Was this on GNOME? I was unable to find a "Configuration panel" when I tried to follow your steps. Commented Sep 23, 2020 at 20:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .