4

I found that Compiz is usable with Xfce and after installing it, adding it to start with session and restarting session, I couldn't access my home folder (I have access to folders that are within 'home/user'). I get this error message: Error stating file 'Home/user/.gvfs'. Transport endpoint is not connected.

I unistalled Compiz and still get the same error.

How could I repair this?

| improve this question | | | | |
  • 1
    interesting - this possibly might work for you? r3dux.org/2011/08/… – fossfreedom Mar 20 '12 at 19:20
  • thank you. IT WORKS. solution amounts to manually unmounting the ~/.gvfs using: $ fusermount -u ~/.gvfs - then unmounting all that's mounted - then logging out, and in. – user47206 Mar 20 '12 at 19:28
  • excellent - have posted this as an answer. – fossfreedom Mar 20 '12 at 19:34
6

There is a rather old bug-report with your error message.

After logout and following login every attempt to access $HOME/.gvfs (i.e. with ls or df) results in 'Transport endpoint is not connected' error message. At the same time $HOME/.gvfs is present in /etc/mtab. Also GVFS-mounts are accessible through FUSE when /usr/lib/gvfs/gvfs-fuse-daemon is called with some other directory as argument.

A workaround suggested was in post#6

manually unmount the ~/.gvfs using:

fusermount -u ~/.gvfs

Then close/unmount all opened remote locations in Thunar/Nautilus and log out and back in, again.

This should restore the .gvfs-functionality

source

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy