I use Ubuntu 18.04.2, I installed lm-sensors and what it gives when I command sensors in the terminal:

(base) avy@avy-Moi:~$ sensors
Adapter: ISA adapter
cpu_fan:        0 RPM

Adapter: Virtual device
temp1:        +27.8°C  (crit = +119.0°C)

Adapter: PCI adapter
fan1:           0 RPM
temp1:        +35.0°C  (high = +95.0°C, hyst =  +3.0°C)
                   (crit = +105.0°C, hyst =  +5.0°C)
                   (emerg = +135.0°C, hyst =  +5.0°C)

Adapter: ISA adapter
Package id 0:  +27.0°C  (high = +82.0°C, crit = +100.0°C)
Core 0:        +26.0°C  (high = +82.0°C, crit = +100.0°C)
Core 1:        +26.0°C  (high = +82.0°C, crit = +100.0°C)
Core 2:        +27.0°C  (high = +82.0°C, crit = +100.0°C)
Core 3:        +27.0°C  (high = +82.0°C, crit = +100.0°C)
Core 4:        +25.0°C  (high = +82.0°C, crit = +100.0°C)
Core 5:        +27.0°C  (high = +82.0°C, crit = +100.0°C)

But my fans are not appearing, and I have 4. 3 only for the box itself and connected to the motherboard, 1 for the watercooling device which is also connected to the motherboard.

Even with fancontrol:

(base) avy@avy-Moi:~$ sudo pwmconfig
# pwmconfig revision 6243 (2014-03-20)
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

Found the following devices:
   hwmon0 is acpitz
   hwmon1 is coretemp
   hwmon2 is asus
   hwmon3 is nouveau

Found the following PWM controls:
   hwmon3/pwm1           current value: 0
hwmon3/pwm1 is currently setup for automatic speed control.
In general, automatic mode is preferred over manual mode, as
it is more efficient and it reacts faster. Are you sure that
you want to setup this output for manual control? (n) y

Giving the fans some time to reach full speed...
Found the following fan sensors:
   hwmon2/fan1_input     current speed: 0 ... skipping!
   hwmon3/fan1_input     current speed: 0 ... skipping!

There are no working fan sensors, all readings are 0.
Make sure you have a 3-wire fan connected.
You may also need to increase the fan divisors.
See doc/fan-divisors for more information.
  • What motherboard model do you have? – rtaft May 29 '19 at 16:32
  • @rtaft Asus tuf z390 pro gaming – AvyWam May 29 '19 at 16:35
  • Are you able to see the Nuvoton chip on the board? What is the model number of that chip? I'm having a hard time finding it online, something like NCT6798D. – rtaft May 29 '19 at 16:47
  • Did sensors-detect see a Nuvoton chip? – rtaft May 29 '19 at 16:48
  • While launching sudo sensors-detect it gives Trying family VIA/Winbond/Nuvoton/Fintek... Yes Found unknown chip with ID 0xd42b (logical device B has address 0x290, could be sensors) is that the kind of information you wanted? – AvyWam May 29 '19 at 16:54

I came across this problem a while back. From what I understand, the kernel is preventing lm-sensors from looking at fan usage, so I modified my GRUB settings to allow lm-sensors to access this information. First, open the configuration file:

sudo gedit /etc/default/grub

Then set the GRUB_CMDLINE_LINUX option to the following:

# This allows fan usage to be read by lm-sensors

Save the file and close, then update your GRUB settings:

sudo update-grub

Executing sensors in the terminal should show your fans' RPMs now. It may be the case that not every fan for your machine is being shown - for my machine, none of the ASST_FANs are shown.

Perhaps I could solve this issue by making a configuration for your mobo, as described here, but I am happy with the information I have been able to get with the adjustment to the GRUB configuration.

  • That's a great idea because I see it works for other people, unfortunately not for me. lm-sensors configs is great too but there is no available for my motherboard asus tuf z390. – AvyWam May 24 '19 at 17:38
  • @AvyWam The only thing I can think of is to run sensors-detect to get information on the motherboard, but I'm guessing you already tried this. – gorgeous.sideburns May 24 '19 at 17:47
  • If to say yes to all scan proposed by sensors-detect get the information on the motherboard, we can say I tried. If this not what you expected tell me. – AvyWam May 24 '19 at 17:50

Go to the standard Ubuntu Software, press Add-ons and go to the Shell extensions TAB. Find "Sensory Perception GNOME Shell Extension."press install.

All temp sensory info are shown next to the clock.

Works perfectly out of the box after a fresh install.

enter image description here

  • I use Freon and it is clearly said in its doc that lm-sensors is compulsory. So it clearly means if lm-sensors does not detect correctly, freon will not too. – AvyWam May 24 '19 at 17:23
  • Tested this with a fresh Ubuntu 18.04.2-LTS desktop install. – Marc May 24 '19 at 20:46
  • Tried, and does not work, that's not a matter of fresh Ubuntu installed. – AvyWam May 24 '19 at 20:56

I think sensors-detect is what is not recognizing the chip. After reviewing nct6775.c again, it should treat it as a nct6798d.

Add the following to the GRUB_CMDLINE_LINUX_DEFAULT variable in the /etc/default/grub file: acpi_enforce_resources=lax then rebuild the grub config grub-mkconfig -o /boot/grub/grub.cfg and reboot. sensors-detect may detect it after that, it may not.

It should be as simple as modprobe nct6775 to get something to show up in sensors once the grub change is working. If that seems to be working, manually add it to /etc/modules to persist the change. You may also need to edit /etc/sensors3.conf to get all correct sensors output.

There is an example Here for nct6791d, it may work, you may need to look for a nct6798d version for sensors3.conf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.