0

For a while now, I've had NVIDIA 418.56, CUDA 10.1, and a 4.4.0-148-generic kernel.

I might have caused issues when I ran dist-upgrade or similar recently; after decrypting the drive, it gets stuck there. This is not an issue with the decryption, as I've also tried recovery mode and logging into the root shell, and I could work with the shell right after it asks for the decryption credentials.

Running startx from another tty did not work, so I thought that I needed to reinstall the driver. I upgraded it to 418.67 and rebooted (confirmed by nvidia-smi), but the GUI still would not boot.

The Xorg logs are shown here. An error is seen:

(EE) systemd-logind: failed to get session: PID 1214 does not belong to any known session

Where do I go from here? I've searched about the topic, and the posts were mostly from a few years back, involving Arch Linux and Bumblebee.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.