0

I'm using Ubuntu 18.04 with kernel 4.15 and installed Nvidia driver 418.67. All of this is installed on the new Razer blade advanced 15(2019) model. When I change to Intel and reboot powertop says its drawing out 40-50 Watts idle and the Nvidia device is not turned off. I've tried a bunch of workarounds including tlp and https://github.com/timrichardson/Prime-Ubuntu-18.04. Afterward doing these tweaks idle draw is around 17-20 Watts. This still seems a bit high and furthermore issuing the commands.

sudo -i
modprobe bbswitch
cat /proc/acpi/bbswitch

it says 0000:01:00.0 ON, so the Nvidia card is still on. Furthermore powertop also confirms that an Nvidia device is still turned on. Can someone please help me to figure out how to completely disable the Nvidia card in Intel mode.

  • Have you tried with Nvidia X Server Settings? – GabrielaGarcia May 23 at 19:51
  • Doesn't sudo prime-select intel do the same thing? Or did you mean something else? I have tried just doing powersaving mode from x server settings and then monitoring using powertop showed 40-50 watts usage after reboot. – thegamer May 24 at 1:37
  • Figured out how to do it with bbswitch installed. – thegamer May 24 at 3:32
  • I now have the power discharging at 10 watts, so that part is now fine. My question now is how can I have tee /proc/acpi/bbswitch <<<OFF run during bootup when in Intel mode only? – thegamer May 24 at 3:36
0

See answer here https://unix.stackexchange.com/a/420273. Once you have switched into Intel mode you can do the command

sudo tee /proc/acpi/bbswitch <<<OFF

to turn off the GPU. Likewise to turn it back on again you can do

sudo tee /proc/acpi/bbswitch <<<ON

Preferabbly I would like this to automatically run during Intel mode instead of manually entering it after every boot. If anyone has a suggestion for how to do this it would be much appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.