4

I am trying to use php memcache extension on Ubuntu 18.04 (nginx + PHP 7.2). Memcached is installed and working but I could not get the php-memcache extension working.

I can install libmemcached11 without any problems:

$ sudo apt-get install libmemcached11

libmemcached11 is already the newest version (1.0.18-5+deb.sury.org~xenial+2).

When I run:

$ sudo apt install libmemcached-dev

The following packages have unmet dependencies:
 libmemcached-dev : Depends: libmemcached11 (= 1.0.18-4.2ubuntu0.18.04.1) but 1.0.18-5+deb.sury.org~xenial+2 is to be installed

How can I resolve this?

3
  • 1
    Try running sudo apt update first, to update the package repository (list over available and current packages).
    – Soren A
    May 23, 2019 at 11:39
  • You have a Xenial version of libmemcached11 installed from a PPA. The PPA was probably disabled during an upgrade to Bionic, so you should re-enable it.
    – fkraiem
    May 23, 2019 at 12:42
  • @fkraiem can you please elaborate a little more? I could not find any disabled ppa's..
    – salihcenap
    May 24, 2019 at 7:06

1 Answer 1

10

I have solved the problem by checking for any leftovers of xenial ppa's and removing them. Then I uninstalled libmemcached11 by:

sudo apt-get remove libmemcached11

And than installing libmemcached-dev by:

sudo apt-get install libmemcached-dev

I hope this solution helps somebody..

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .